Streaming live at 10am (PST)

CMS Editor frustrations

I’ve been using Webflow for a few months now and on the whole I’m pretty happy with it apart from 1 exception - The cms editor!

It’s hands down the worst I have ever had the misfortune of using. I’m constantly finding myself having to log out and back in. There’s issues uploading files to the CMS, if I log out and back in works fine. I find the text buggy in Chrome whereby line breaks don’t work correctly, etc etc etc.

All this is seriously slowing my work flow down to the point I’m wondering if this is worth continuing with.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi, @jg9!

My name is Ben and I’m happy to help you with this issue! I’m sorry to hear that you’re having trouble with the CMS. I know you titled this CMS Editor, but are you seeing these issues primarily in the Designer or the Editor?

What project are you working on when you are seeing the issues?

Are you still seeing the issues while using your browser in Incognito mode in Chrome or Private mode in Safari with extensions turned off? There are some extensions that are known to cause problems with Webflow. You can see that list here:

Also, would you be able to use a tool like Cloud App to provide me with some screenshots or a short video about this issue?

Any extra context or information you could provide would be very helpful! :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.