Streaming live at 10am (PST)

CMS Gallery (mobile)


#1

Hi,

I am currently redesigning my portfolio, and I am trying to use the CMS more.

For photography i have both landscape and portrait pictures, and in desktop this is not a problem. (Using dynamic list for display)
I have them as background image / no-tile / contained .

The question comes when I go to mobile browser, I would like the portrait images to go full screen, while still limiting landscape height. As of now, I have a max height- which makes portrait images very small.
If I increase the box height, the landscape photos get a lot of white space between them. Any tips?

(Last resort is to ditch the cms, and use regular divblocks)

EDIT: The reason this is a "problem" is that in DESKTOP mode, I have the background images fixed.
Although, since mobile devices have fixed disabled, I need to adjust the images.

EDIT2: I answered myself here. The solution was to hide the first Dynamic List (in mobile devices), and create a new one that is only on mobile devices.. That way i can set up an IMAGE ASSET linked to dynamic content on mobile devices, which creates the height itself (and also by setting max height to not screw up)

Karl


#2

Share a public link mate, else I can't really visualize what you're talking about.


#3

Sorry about that;
https://webflow.com/website/KM20?s=km20

Menu > Portrait Photography > Mobile

Right now i set the height high, and get the gaps.


#4

What if in mobile, you set the background image to Cover instead? That would take up all the available space, but you would have cropped up parts as well. And your 2-piece image won't fit nicely as well, but I think you can change the image slightly.


#5

Well, the problem is that using "Cover" will remove 60% of the image. Not very good for photography compositions...

I am considering removing the CMS from the Portfolio sections. It's actually there as a "test-run" for another part, to see how CMS galleries could work for future use. Just trying to make use of the potential, but this kinda made me stuck.


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.