Streaming live at 10am (PST)

CMS grid leaves first slot empty

Hello fellow Webflowers,

I have a weird thing going on with one of my collections. As display:block it works fine, but once I make the collection a grid, the first grid remains empty. As far as I can see, there’s no object that’s too big for the collection item. Does anyone have any idea what causes this? This concerns the page Blog Archive in the folder EN (live site: https://privacycompany-test.webflow.io/en/blog-archive)

Thank you!


Here is my public share link: LINK
(how to access public share link)

1 Like

As you can see, there’s nothing there…

I’ve tried but without success.
Curious to learn the solution.

Thanks for trying anyway!

Anyone else wants to take a shot?

Same exact issue—bummed, because I have to use dumb workarounds for the time being.

I’m very bummed as well. It seems like this weird empty cell is the case in every single CMS collection grid I have, and in none of the regular grids, regardless of whether or not auto-fit is enabled… This means I cannot use display:grid whenever it concerns a collection.

Having this issue as well… Going to try moving to Flexbox, but it takes a lot of the gas out of Grid 2.0 for me.

Hi @Tessa and fellow Webflowers!

Here to provide a solution for this issue of the first grid area being empty. It seems to be happening because the collection items have a float property of left. Once this property is removed the first grid area is no longer empty.

I’ve created a short video to further clarify using Tessa’s example: https://share.getcloudapp.com/NQueBeyl

Hi John,

Thanks for taking the time to explain this! I got it to work on one page, but on other pages it didn’t work as expected yet. I was in a bit of a rush (website needed to be published yesterday eve), so for the time being I have put it back to flexbox wrap, and I’ll check this out better once the dust has settled down. In any case, the float: left turned out to cause a minor alignment issue in those overviews, so you helped me fix that :blush:

Thanks again!