Streaming live at 10am (PST)

CMS links not displaying in published version of page


#1

I have been trying to teach myself webflow and I just can't figure out what's gone wrong here; I didn't have this problem before now. I have a dynamic list on a splash page that is supposed to link to different unit numbers. The non CMS link works, but the CMS links have stopped displaying in the published page.

Although they are invisible, the links still work when set correctly. I've tried manipulating settings and turning on and off all the transitions and opacity effects I can think of and still can't get the dynamic list to display. It's probably that there is some damn setting I can't think of that is keeping it from displaying, and I apologize for needing it pointed out to me. Here is my read only link: https://preview.webflow.com/preview/aspectsoftheorycommunication?preview=6562859b8c21bc9ae1ecc48e204b387d


#2

So your structure is that:

The SPLASH element has an interaction saying: onLoad of the page, opacity zero, so that's normal it doesn't appear.

What's more disturbing is the parent element, Home Page Link List, also hve THE SAME interaction saying onLoad of the page, opactity zero.

So there's a double reason for your content to be invisible : the same interaction passes it to opa zero on the load of the page. Twice.


#3

I'm just a little confused; the starting appearance opacity zero is set to go to opacity 100% over 1.5 seconds. It's actually the same transition element the non cms content is using as well. Why would it work for the non-cms content, but not the cms? Additionally, setting all of the transitions to none still did not cause the links to be visible. Is there a different place the opacity is set to 0%?


#4

I got it to display by creating a 2nd dynamic list underneath the first one, and giving it all of the same settings. After setting the second dynamic list to the home page link list style and only setting the links the way described above, only the links of the 2nd dynamic list stopped displaying; but also the first dynamic list became totally visible again. Somehow making more items using the same style without altering that style's properties made the 1st items visible again.


#5