Streaming live at 10am (PST)

CMS no longer accepting pasted images?


#1

Hi,
We copy content from Google Docs into the CMS for 95% of our articles, and previously images would in GDocs would be pasted in without an issue. However, it seems that the CMS has suddenly stopped accepting them. See below for the Google doc and the result in Webflow:

to:

and this message has started appearing:

image

Is there any reason why this has changed? It’s going to cause us a fair amount of extra work if we have to source images for our writers.

Advice appreciated.


Here is my site Read-Only: LINK

Published link:


#2

Update - this isn’t just Google Docs. It is any copy and pasted image, even within the CMS itself. So if I have an image in an article and I want to cut and paste it to another location in the same article, I cannot.

Any ideas?


#3

I just tested it with a few different sources, and I get the same result as you. Any image is replaced by Webflow’s .svg placeholder graphic. Hope that it’s a bug.

cc @Brando can you make sure this is taken into account? Thanks!


#4

Heyo @andyp2 @vincent

Thanks so much for posting and great questions. To clarify, this is not a bug but due to a recent update we made to rich text that changes how we handle pasted images.

Customers were having a few issues previously when pasting externally hosted images into rich text elements or rich text fields – some examples:

  • If if the content was copied from a google doc and you later delete the google doc it deletes the hosted image which breaks the site you pasted it into
  • If it’s from a google doc that is not publicly available, it’ll look to you in the Designer that the images pasted ok, but to everyone else it looks like a broken image

The update and expected behavior is that on paste, we are now prompted to manually upload these images to ensure they get uploaded to Webflow as a host rather than just referenced from another source.

The next step is to add support to auto-import all pasted images so they end up as part of the site and hosted on our infrastructure automatically. But until then we’ll need to manually upload images (although we don’t have an exact timeframe for this).

I hope this helps and let me know if you have questions.


#6

Thanks for getting back to me. A shame that this has no timeframe to resolve as we handle dozens of images each week in articles, which need to be transferred to Webflow. I hope this can be addressed soon.


#7

OK, thanks.

Any ETA for the new behavior?


#8

Hi @andy

While the new behavior isn’t as quick as the previous behavior, we feel it helps prevent a lot of frustration in case the original src URLs for these images are lost – in which case all images on your Webflow site would be subsequently lost and unrecoverable.

@vincent – we don’t have any timeframes at this time as to when we’ll implement this second phase but we’ll be sure to communicate it when we do :slight_smile:


#9

I can’t add any pictures into the place holder pic now. This is very frustrating. Please let me know how this can be done.


#10

I see this is now fixed - thanks!