Streaming live at 10am (PST)

CMS Template Page not used?


#1

Hi All,

I build a website using the CMS collection and as far as I know there is no way to unbind the collection page template that is automatically created. I don’t need the page (common problem) as the collections are just to pull data from them.

From there I have 2 issues:

  • Explaining to the client that all the pages in the editor (under the static pages section) are actually blank pages and there is nothing to edit on them (making the editor page section quite crowded)

  • Having the ability to reach this page by entering the URL which leads to a beautiful empty white page…

I wanted to at least avoid this second one and thought about redirecting collection page to the master page.

For example: When accessing website/membercollection/member1 redirect to website/membercollection OR show a 404.

I tried to explore the 301 redirect options in settings but I can’t make it to have the desired behaviour.

Is there a soul out there who might have some leads on how to achieve this (with custom code maybe).

(no read-only on this one as it’s more a general problem than a specific one)

Thank you in advance.

Max


Here is my public share link: LINK
(how to access public share link)


#2

Put this in the custom code HEAD part of the templates:

<meta http-equiv="refresh" content="0; url=https://example.com/">

Url is the page you redirect to, 0 means 0 seconds delay.


#3

Merci @vincent ,

It does the job, hopefully there will be a way to disable collection templates in a “near” future

Au poil :ok_hand: