Streaming live at 10am (PST)

CMS Validation Error after Successful Zapier

I have set up a zap and tested and the test goes through fine with no errors on Zapier’s end. I have the zap send the CMS item as a draft because I need to go in and update a reference field since the Zap can’t do that part. After doing so, I try and publish the item but receive a validation failure. It asks me to republish the site before commencing, which I do, to no avail.

What could be the issue?

The collection is “Purchase Histories” and the item is “Restaurant Menu”


Here is my site Read-Only: https://preview.webflow.com/preview/n3tworth?utm_medium=preview_link&utm_source=designer&utm_content=n3tworth&preview=9da57560440c1ff741d3cdaebeea3365&pageId=5d0219bb3b51f90df35328c6&itemId=5d0a034d7f6894534687cd74&mode=preview

Thanks in advance!

Hello, @n3tworth! :wave:

Ben here with the Webflow Customer Support Team!

I’m taking a look right now at this issue and I’ll let you know as soon as I have more information!

Hi, @n3tworth!

After doing some investigating I think I’ve found the field that’s causing the problem. See this screenshot:

CloudApp

I don’t know where that text is coming from in the Zap, but it looks like there may be an issue with a hidden character in that field that’s causing the problem.

I cut that text out and used Shift + CMD + V (Shift + CTRL +V on Windows) to paste it back in and I could publish and stage for publish.

Can you take a look at that field or share some more information about your Zap so we can take a closer look? Thanks so much!

1 Like

Ah I see! I don’t think there’s any line item support for what I’m using (Foxycart) and the error is somewhere therein. Basically that field spits out all the options a user chose at checkout.

My Zap: A new transaction in Foxy is made > A live item is created in WF with all the information from the purchase

Foxy doesn’t have a customer portal yet so I was trying to use Zapier to pull in all the information and spit it out into WFs CMS. Knowing what it is, at least now I can manually update.

Thanks for figuring out a workaround to the issue!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.