Streaming live at 10am (PST)

Collaborator Invite/Direct Links Not Working


#1

I have run into an issue with various clients on several sites where.

  1. Invited Collaborator does not receive an email invitation.
  2. The direct link does not load the portal to allow them to create an account.

Sometimes reloading several times fixes problem 2. Other times it does not.

Does anyone else have this issue?


#2

Hi @Jason_Green,

This definitely sounds like odd behavior.

I tried reproducing this behavior on my end but was unable to.

Can you please try the following:

(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: https://support.google.com/chrome/answer/95464?hl=en

(2) If the problem persists, please take a screenshot of your Console and send it to me: https://cl.ly/2Q2l1g0B3v0s

Also, would you be able to let me know what browser version you’re using by sending me your information from this page? https://www.whatismybrowser.com/

There should be a small share link when you visit the page which you can send to me.

Thanks in advance! :bowing_man:


#3

This mostly seems to happen on the client side and only for the initial invite.

I have had various clients try various browsers with varying levels of success. Worst case being, they are unable to create an account at all via the direct link. I think the link is not prompting Webflow to launch the account creation pop-up.

It seems that no one receives an invite to become a collaborator via email though.

The collaborators who have been able to create an account have no issues logging in to the site.


#4

Hi @Jason_Green,

This is odd, but may be due to a conflict with browser extensions which is why the suggestion to use Incognito mode.

We would suggest when your clients receive the links, to copy the link in the invite mail and paste that into their browser that is running Incognito mode.

Then, they should be able to complete the account as expected.

If not, please let us know as we’d be happy to help :bowing_man:


#5

Ok, I figured it out. There were two things causing an issue on my end.

  1. I almost always have white labeling enabled - which keeps the auto email from going out. I didn’t know this. (Might be worth noting someone on the editor invite section)
  2. For this particular site I have a collection page as the “landing page” so there is a javascript redirect from the main URL.

I had to amend the auto generated link to include the full URL of the re-direct.

Problem solved.