Streaming live at 10am (PST)

Collection list, sort on toggle switch not behaving correctly?

Hi guys! My first post here.
Im having a sorting issue on our site. We had two items, when toggle on it would display above all the other posts / articles. However, when disabling the toggle from our oldest post it still displays “on top”.
Created on date is old so it should respect that as well…

Hope i posted this in the right section. Thanks in advance for any help that could resolve this.
Attaching some screenshots to further explain.

Cheers,
Tom


Public share link

Link to live site

Hello.

I’m not sure what the order should look like - but have you tried switching the ‘Sort Order’ options (putting ‘Created On, Newest to oldest’ at the top). When I switched them then the content shifted and the Webflow post moved to the last page. If you’re looking to hide older posts, then I would suggest using a filter.

I hope this helps!

Hi and thank you Nicole! I tried doing that but the oldest one still appears on top… The article “Webflow” is actually the first and oldest article, but used to be “sticky” with a toggle. Now we just want one article to stick, but somehow that Webflow article remains high up regardless of what I do… See video:

Screen recording

Thank you so much!

Tom

Hello.

I think I understand. If it’s only one article you’re looking to have - then a filter makes the most sense. If you’re just looking to have the oldest at the end - then see video attached. It shows me switching the sort order options. I’m sorry I cannot be of more assistance.

Good luck!

Hi and thank you for your valuable input, but as you see when you do that the one which is supposed to be “featured” / on top (blue banner, white text) is shifted down as well.

Thank you for your suggestions Nicole.

Cheers,
Tom

Hi Tom,

It looks like the created on date is being ignored as the second level criteria in that sorting using the toggle swtich, I am helping to take a look further into that. In the meantime, I would create two separate collections, just duplicate the collection list:

In first list, delete the sorts and add a filter, too show only articles with the featured flag on:

In the second collection list, do not use a filter, and remove the toggle switch from the sort:

Then using the two lists the expected content should show.

I hope this helps, when I have more info on the sorting behavior with toggle/created on combination, I will provide an update.

Thanks in advance.

1 Like

I ran into this problem as well, and solved it like cyberdave is describing - by having the top article it’s own collection list. Remember to filter out the “fremhevet artikkel” from the bottom list.

Hi @cyberdave! That did the trick. To not get duplicates I had to create a filter for the regular list wrapper which indicated: “Featured article toggle is set to off”. Thank you for the solution. This will surely be fixed since it is to be consider a bug right? But this really really helped.

Thank you so much! :slight_smile:

Cheers,
Tom