Streaming live at 10am (PST)

Collections Not Showing on page

Hi Guys,

I’m hoping one of you good people may be able to help.

I have a site that has two collections, one for News, and one for Careers (each on the News page and Careers page).

The collection on the News page shows up no problem and behaves as expected. But the Careers page doesn’t show the collection at all, even in Designer view. It shows the CMS widget, but doesn’t render that collection list.

Is there something obvious I’m missing? It was all straight forward on the News page, but the Careers page isn’t behaving at all.

Any help is deeply appreciated!

Thanks a million,

billy.


Here is my site Read-Only: Webflow - PlantQuest
(how to share your site Read-Only link)

Hi @billy.rooney :wave:

So you will need to still add content to your Careers Collection List, so that you can bind it to the necessary data.

You could either copy the News Collection List you have, unlink all of those fields, and re-bind them to the Careers data you have, or build out a new one.

The reason is that each collection often has different data structures. Some will have more headings, text or number fields, so it’s not just a case of copying your list and reconnecting it.

Here’s a video which I hope makes some sense to you, please let me know if I’m way off the mark though :smiley:

Oh Wow, thank you so much for your prompt reply, that video walking me through what to do is insanely helpful and solved the problem I had completely. So yeah, you nailed the issue and the solution, everything is working now, and thank you again for such great support!

All the best,

billy.

1 Like

AgedCrispHamadryad-size_restricted