â–¼
Streaming live at 10am (PST)

Column Margin Issue


#1

In my test... I dropped a ROW directly into a SECTION.
No classes on the SECTION or ROW.

It appears... the COLUMN of a ROW has a built-in LEFT and RIGHT MARGIN of 10 pixels.

You can see this adding a ROW - then adding a class to the one of the columns.

The 10 pixel left / right MARGIN will appear. The MARGIN is always there - but you cannot the values until you class the COLUMN.

If you drop a DIV into COLUMN 2... the DIV is incorrectly positioned inside the COLUMN... about 20 pixels down.

If you class the DIV... and add a ZERO (0) top MARGIN to the DIV... the problem doesn't do away.

If you change the DIV's top MARGIN to 10... the DIV is repositioned correctly (occupying / moving to - the top of the COLUMN)... but the MARGIN is about 20 pixels. NOT 10. The only way to fix this is change the top MARGIN of the DIV to 1 pixel. You will always be 1 pixel off though.

If you drop a ROW directly into a SECTION.

Then drop a DIV into COLUMN 2 of the ROW...

The DIV is positioned about 10 or 20 pixels below the COLUMN top.

If you create a class for the DIV - and add a 10 pixel margin...
the DIV is repositioned (correctly) to the top (zero 0) of the COLUMN.


#2

10px PADDING

No it doesn't.


#3

Hi @Revolution, I am sorry to hear about the column margin issue. I see @vincent's findings, I am also going to go take a look and get back to you as soon as I can smile


#4

EDIT: SLIGHT NOMENCLATURE ISSUE... meant PADDING on the COLUMN - not MARGIN.
Yes. It Does.

In the video below... I have SECTION -> ROW - COLUMN 1 / 2 -> DIV

The SECTION is classed only to provide a NAME... nothing else.
The ROW is to provide a background image. Nothing else.
The COLUMNs have a built-in left /right 10 pixel PADDING.
- You only see this when you class the COLUMN.

and the COLUMN has an INVISIBLE 10 pixel top PADDING... which you see never... unless you look at the live preview.

The DIV... is classed... but has no top PADDING.

With the (DIV) PADDING at ZERO - notice how far down the DIV positioned... about 10 pixels.

When I set the top (DIV) PADDING of the DIV to 1... notice the top PADDING of COLUMN2... disappears.

http://quick.as/4ZyqTggd

I cannot open the project for public viewing right now.


#5

But again:

If you drop a div into a column, it does not get incorrectly positioned.

Your video shows only what it shows, which may not be enough to understand why your elements are rendered like this.

Can you please share your project’s public link so it's easier to understand your issue?

Learn how to do it here: http://help.webflow.com/sharing-your-public-webflow-site-link


#6