Streaming live at 10am (PST)

Columns are killing me!


#1

I just started to use Webflow I usually use Wordpress. I like it but things that seem like they should be simple are a bit more complex than I think they should be. For example, columns...

I have a background section a hero section and nav bar set up. I want to add columns underneath that section for txt. When I add the columns they automatically position themselves in the middle of the hero section. I moved the margin down about 500px to where I want them to be and its fine but I don't think I should have to do that. I put my content in both sections but there seems to be no easy way to center the entire content block. I have all the settings on auto at this point ( i have tried a bunch of stuff but nothing really gives me what I am looking for. Also there is a bunch of extra space on the right side of both content blocks.

If someone could help me understand this I would be grateful.


#2

@soulluciani Hi, can you provide the read link for your site? I'll take a look and see if I can offer anything and I'm sure some others may as well.


#3

I recommend you watch the tutorial videos at http://tutorials.webflow.com Most of the basics to webflow are in there that will help with your positioning issue.


#4

Here is the link. Thanks for taking a look!
https://preview.webflow.com/preview/soul-lucianis-ultra-awesome-site?preview=3bc979910568cd4fae57aef716324e04


#5

@soulluciani Ok, here's my recommendation after looking at it. You had some things positioned incorrectly and inconsistent margins (and/or padding as well). It would be easiest to drag out new elements of:
section, container, and column in that order and then drag in your text. You will find that the items don't overlap and that they have a small margin (or padding) on the sides. Actually you will also want to get a consistent styling on the text for the margins and that's easy by adding a new style under the selector.


#6

Thanks GodlessGlen. I went over those tutorials again last night and realized that I didn't have the proper structure and started again from scratch. Its looking good now.


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.