Streaming live at 10am (PST)

Colums not visible in smartphone (horizontal & vertical) view


#1

I build a basic webpage with a section, container and 3 columns. In the PC/Laptop and Tablet view all is fine, but in the smartphone view the columns disappear and are not visible! I am used to set the amount of columns per device but in this case that does not seem to work. Can someone please have a look?

https://preview.webflow.com/preview/mosadex-experience-2017-pearl-edition?preview=8040fe82c88ede18e12f4670858f975a

password: me2017pe

Thx for your help!
Daniel


#2

Hi @daniel_volle_maan

Looks like the columns have display setting: none applied to them on mobile-landscape view that is why they are hidden.

If you want the columns to show on mobile, remove the display setting on all columns.

​Hope this solves your issue.


#3

Hi Anna,

Thanks you so much for looking into this. I got part of the problem solved but only part of the columns show up…could there be something else wrong in the way I set this up?

Thx!
Daniel


#4

You have to remove the display setting on all hidden column classes.


#5

As far as I can tell I have done that…I selected all the columns and all of them should be displayed.


#6

So, are there any other issues or is the problem solved now @daniel_volle_maan ?


#7

No I did not get the issue solved yet…I think that all columns are set to be visible but not all columns show up when you are in smartphone view. See the first column for example, “Hoe werkt de app in de praktijk*”…in smartphone view this is not shown. There are more examples of this happening. Could you please have another look for me? Thank you so much!


#8

I changed all columns to column3 style…this works out, all columns are visible right now!


#9

It’s not solved yet @AnnaKelian ! Only in the preview mode of webflow itself, however when I have a look on multiple smartphones, only column 3 is being shown! I don’t get what is going wrong, usually setting this up is super easy…


#10

Hi @daniel_volle_maan

I see that column and Column 2 are still hidden on both Mobile views.

Make sure all classes applied to your columns are visible on all breakpoints.


#11

Thx, I removed all the classes and now it works. The class that caused the issue must have been “heading small” since this class was only found in column 3…Thanks for having a look!


#12

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.