Streaming live at 10am (PST)

Combining Page Load Animation "while loading" + "when loaded" won't work


#1

Dear all,

I am trying to setup some animations while the page loaded already and some others while the page is still loading.

Now the odd thing is: Whatever animation I select to be used for “When Page Starts Loading”, won’t work/animate at all. I already tried swop them and then the one that worked previously doesn’t work anymore and the other one works.

It should be possible to use both triggers at the same time according to Webflow University Video, no?

Thanks!


Here is my site Read-Only: https://preview.webflow.com/preview/smartmicethailand?preview=0583423eacf187e68ba856842b8a4c8f


#2

Hi @Idext,

I’m not really sure what is occurring and I can replicate your issue.

The way I understand your project thought you don’t need this.
Because both of your animations needs assets why not waiting for assets to load for both animation?

You can set up 2 page load (when page is loaded) animations to separate them and add some extra delay to one of them if you want some overlapping actions.

As well your declaring 2 initial states for the raw. Just set it up once per element otherwise you would run into some unexpected behaviour.

I hope it makes sens and helps


#3

Dear Maximosaurus,

Thanks, initial reason was that I wanted to prevent too much time passing by until page is loaded. On the other hand if half loaded images etc. fly around is weird as well.

That’s why my thought: Why not play first seen elements’ animation immediately and the rest followed once all content is really loaded. And in Webflow University they say it should be possible to do.

Now since it doesn’t work I combined it as you wrote but would still like to know why it doesn’t work. If it doesn’t, shouldn’t be possible to setup the way I did otherwise it is confusing.

Let’s see if from official support someone has some input.

Thanks again for your reply!
Stefan