Streaming live at 10am (PST)

Contact Button not showing properly on mobile


#1

I needed to create a non-link in my navigation for Contact since it's a one-page design. It works fine, but on mobile devices it shows centered in the drop down instead of left justified like the others. Any idea how to fix?

https://preview.webflow.com/preview/okaircraftfinancing?preview=05ba216ac55222d2eac7634786bdeeeb


#2

You can fix it by making the contact button a block and the left justifying it. This should make it look like the other menu items.


#3

Thanks, but that didn't fix it; just put it on the right side of the mobile nav.


#4

Hi @chrisgreer33, thanks for your post. Starting at Tablet view, Can you try to set the nav-link contact class to display block and see how that works for you ? See my screenshot:

Cheers, Dave


#5

Thanks Dave. That fixed it.

Now onto issue No. 2, how do I change the hamburger nav box on tablet from red to another color? It shows in the style menu that it's transparent, but it's red when you click on it.

See captures below:


#6

Hi @chrisgreer33, thanks for the followup. Go to tablet view. Select hamburger icon. Go to the settings panel and click Open Menu. Notice you now have the hamburger icon open class highlighted. Go down to fill color and change as needed.

See video:

http://quick.as/a9XqfaY5P

Hope this helps smile Cheers, Dave


#7

EXCELLENT, and outstanding help as usual CyberDave. You continue to be a rock star and life saver.


#8

OK. I sort of lied. One more question on this page ...

In the "Contact" field, I added a selection field ("How would you like to be contacted?). Despite me setting the font color the same as the other fields, it's a darker black. How can I get it to match the color of the other fields?


#9

Hi @chrisgreer33, I'm not 100% sure if this answers your question entirely, but have you had a chance to use the swatches feature yet?


#10