Streaming live at 10am (PST)

Contact Page not showing on web


#1

So i added a contact page to my website and i published it..i checked the spelling,i checked the link and all is fine...it will not show up on web....any ideas ??? Take a look for me at junk-cars.webflow.com .Is there a reason it is not working ? I am using Google chrome as well.


#2

Hello @Paul2, I believe your problem is that you are using absolute url in your link to the contact page, and since there is no page can be found right at that absolute url, you get 404.

Perhaps you have an incorrect url also, that the page does not exist.. but I think in this case, if you are creating multiple pages in webflow, and you are using nav links to move from one page to next for the same website, you should use the option in the Nav Link settings, to "Go to another page".

Using this option will put in a relative link to another page created in webflow, and the links should then work... like I said, this is the easiest thing to do to correct the problem.

This also has a benefit, that if you export your site from webflow to put on another server, like for a client, then those link paths will be relative and will not be hard coded to a particular site domain. Now, in some cases, like when using an external link to a different site altogether, then it is ok to use the full url. There are also cases where some scripts or plugins may need to have the full url put in, but the more you can keep things relative, the better.


#3