Streaming live at 10am (PST)

Copy & Paste in Safari 11


#1

Copy and paste isn’t working in Safari 11. Has anyone experienced this? Not sure if it’s because I have something disabled or maybe it never worked…


#2

I’ve never tried designing in Safari. I believe Webflow recommends using Chrome since it’s set up better for web apps.

That being said, I could not use copy and paste of urls (even in Chrome) when attempting to paste inside of a symbol. What are you trying to paste? Are you pasting it into an area that is currently set as a symbol?


#3

Copying and pasting of items in the Navigation (layers) panel doesn’t work for me in Safari.


#4

Hi @aeko

Thanks for posting about this.

That definitely sounds odd. I just tested this with Safari 11 on Mac OS X 10 and was able to copy/paste as expected. In this GIF I select an element in the navigator, then use keyboard shortcuts to copy/paste. I also tried with the context menu:

Are you seeing something else on your end? If so can you please provide more information?

What sites are you seeing this issue occur in? When did it start occurring? Can you send me the site Read-Only links please?

Can you please try the following:
(1) Try to reproduce the error while being logged into Webflow using Incognito mode with browser extensions turned off: https://support.google.com/chrome/answer/95464?hl=en
(2) If the problem persists, please take a screenshot of your Console and send it to me: https://developer.chrome.com/devtools/docs/console

Thanks in advance and I’ll be standing by for your response!


#5

I’m not using Chrome, so the links about turning off extensions doesn’t apply, but I turned off extensions and it was still happening. The alert dings every time I try to copy and paste in Safari 11.0.3.

I tried taking a screenshot of the Console, but all it had was a warning about not pasting code there from Webflow.


#7

@aeko

Thanks for the update on this. I’ve passed this along to the team and we will continue to investigate this issue.

In the mean time the best workaround is to use Chrome when editing in the Designer. I’ll post back here with an update as soon as we have one.

Thanks for your patience!


#8

This topic was automatically closed after 60 days. New replies are no longer allowed.