Streaming live at 10am (PST)

Credit card declined - Can't add a site plan

Hi everyone, i’m trying Webflow for my portfolio and I really like it :slight_smile: . However, i want to add the 15€ Monthly site plan but both of my credits cards get declined. It’s been 4 days since i try to add a plan and my cards work perfectly fine on other website.

Do you guys have any suggestion to solve this problem ?
Thanks in advance for the help.


READ-ONLY website :
https://preview.webflow.com/preview/sblyfolio?utm_medium=preview_link&utm_source=dashboard&utm_content=sblyfolio&preview=18004cb0f1816ebf769228cd6c7ebe4b&mode=preview

Hey there!

Have you tried reaching out to your bank to see if, for whatever reason, they’re blocking the charge from going through. I have had online services like this get blocked before because they’re deemed “suspicious” (probably because all the magic involved :stuck_out_tongue:). If this is the case, your bank should be able to just remove the flag that is keeping the charge from going through, and you can try purchasing the plan again.

Outside of this, you will likely have to reach out to the customer support team directly by clicking here. Once you’re on the page, you can click the message icon in the bottom right hand corner, and follow the prompts from the support bot. Don’t be alarmed, the bot is just helping to find possible resolutions to your issue by looking at articles already in the support database. If there isn’t an existing article about the issue, you will be prompted to enter some information that will be passed on to the support team.

As @Drew_Schafer earlier on the forum, they have been getting a lot of support requests recently in relation to their support team size. So keep in mind that it may take them a bit to respond.

In the meantime, you could always attempt to run your first month of the Site Plan on a different credit/debit card. After the issue is resolved, you can go back in and switch the card over for future renewals.

Hope this helps! :slight_smile: