Streaming live at 10am (PST)

Credit card fields not working

The credit card fields on my checkout page aren’t working (I can’t enter any text). This is obviously a major issue since I can’t accept any payments!

The solution cited here doesn’t work and isn’t even applicable anymore since Webflow disabled flex for credit card fields.

Anyone know how to fix this?

@mikeyevin Thanks for your reply, but that’s not my project. It’s someone else’s. You can see mine at www.trumpdonald.us/checkout

My apologies @liam, I mistook the last thread you replied in as your own (I’ve been working too long today) however without a link it’s pretty difficult to diagnose any issues.

I went to the provided checkout page and confirmed the same issue on my end, but strangely it appears like the fields in that section all deselect immediately after they’re clicked. I don’t see any console errors, so I’m thinking this may be a bug.

Can you try clearing all of your styles from that section and republishing to confirm it’s not a styling issue? If that doesn’t help, I’d recommend contacting support regarding the issue.

Edit: I went ahead and checked a current ecom project I’m working on and see the same issue, although my checkout is disabled at the moment. Assuming yours isn’t disabled like mine, this looks to be a bug on Webflow’s end.

@mikeyevin Thanks for following up. Yes, the bug persists even when I remove the styling. I think I may need to do more to fully set up checkout and ecommerce generally. I’ll try that next and let you know if it works.

Wish they had more useful error messages!

@mikeyevin When I fully setup ecommerce (connected Stripe and enabled checkout) the fields work. The styling isn’t working very well, but I can enter text now