Streaming live at 10am (PST)

CSS Grid Landscape bug

#1

Help me please, I don’t understand what could be the problem.

So here is CSS Grid, it have 3 columns, on landscape it must be 2 columns. It’s works, but if I try hover on one column the glitch effect appears. Tell me, where does the third column come from when hover?

Here is my site Live Page: http://broplayground.webflow.io/bug-css-grid-hover

Here is my site Read-Only: https://preview.webflow.com/preview/broplayground?utm_source=broplayground&preview=199fd3556254ef8e33b2beec09ee2264

#2

This is a common bug by now. Should be sorted in the next grid update. Until then, this is caused by grid elements that have ended up in what’s called a ‘non-existing grid track’. Finding those elements and manually changing their placing should fix it.

#3

You mean now its really fix this bug? If so, can you show how? I try rebuild this grid, and manually (numeric) change elements position, but see same buggy result.

#4

Hi, @bro-design! Yes, this is a known bug that the team is currently working on a fix for!

But, in the meantime you might find this post to be helpful:

Let me know if you have any other questions! :smiley:

Bug with position: fixed
#5

@rileyrichter
wow

I already thought to redo everything anew by flex box. But… It’s works, thank you big!

1 Like
#6

:joy: :joy: :joy: You made me spit out my water!!! Laughing so hard! LOVE the gif!

So glad we could help! Don’t hesitate to reach back out if you need anything else!

#7

@rileyrichter :+1: Sure, I am too very interested in participating in the improvement of Webflow :v::blush:

1 Like