Streaming live at 10am (PST)

Current state on static URL link

I know this probably has an easy fix, but I can’t find it or a solution in the forum. I have a bunch of links in my navigation that need to use the CURRENT state, but I can’t get this to show as they are straight URL links.

image
image

I have to use straight links otherwise I reach the 20 Collection list limit for the page.

Anyone know how to set the current state in this case?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Hi

I can’t understand the problem? What You clicking on, that shows the attach screen shot?

It’s a text link element

witch one? witch page?

Is it this text? as shown in the image below?

I don’t think it particularly matters, but the link in my example above is here: https://brahmanhills.webflow.io/weddings

It’s in the last link in the sub navigation.

Point this link to the page you are designing now. Select it and it will be current. Style as necessary, change link target.

That seems legit @dram, but the problem is I can’t link to the page.

It’s a CMS page (category of the blog) and I can’t wrap the link in a collection list as doing this in all the places necessary will push me past the 20 per page collection list limit.

Then place this link element on the home page, link it to home page and style it there, then put it back where it should be.

That won’t work. Maybe I’m not explaining this correctly. Try your suggestion in the the read only link and I think you’ll see what I mean.

I am sorry but I do not understand the problem.

Thanks @dram. Eventually got it to work. Very fiddly - even following your video it took me a few tries to get right. Wouldn’t have gotten it right without you, cheers.

1 Like

Good to know you made it work!

I spoke to soon. It’s actually not working out. I’ll post a video to explain the issue, but I have to move on for now.

Yeah, screen recording would be nice since currently it isn’t clear what could be wrong, sorry.

Hey @dram, I’ve done a screenrecording

It seems to just revert once I put the full link in.

I can make the project clone-able?

Checked myself. Yep, simple links won’t register as “current”. Looks like webflow adds its w--current class only for the links that were created using page selection dropdown.

Pity, thanks for testing it out and coming back to me.

@dram I found a good way to hack this if you ever need it…

<style>
/* Links with "stories" anywhere in the URL */
a[href*="stories"] {
   color: hsla(104.21052631578945, 16.96%, 56.08%, 1.00);
} 
</style> 

Yeah, but you’ll have to do it for every page.

Naa, it’s only for the collection page for Stories and the one for Specials. The stories one is working great: Eg: https://brahmanhills.webflow.io/stories/stay or https://brahmanhills.webflow.io/stories/weddings

I’ll have to figure something else out for Specials as there is a primary nav link that also has “specials” in it.