Streaming live at 10am (PST)

Cursor Probz | Help me... it's a simple one I think

hello–
first time posting in the forums!
Having some trouble figuring out what the heckers is going on with my custom-div cursor. it’s all pretty simple, and covered in multiple posts I’ve seen:

A guide to custom cursors in Webflow | Webflow Blog being one of them.

I’m experiencing some glitch where the positioning (i think?) of the cursor element OR the neighboring page elements are in conflict creating an offset distance. IE. actual mouse position isn’t getting properly tracked.

Send help, or crackers.


Here is my site Read-Only: https://rappold-co.webflow.io/

Hi Christy, welcome to the community!

It’s a little hard to judge from the live site. Could you provide the read only link of your project so we could have a look into the actual webflow setup?

Currently, I can’t see any custom cursor on the live site but noticed that the default cursor disappears as soon as I hover your navlinks.

Not having added this custom code to an HTML embed on your page could be a reason for conflicts:

Ah! okay wrong link sorry. Here we go:

https://preview.webflow.com/preview/rappold-co?utm_medium=preview_link&utm_source=designer&utm_content=rappold-co&preview=e5678db147150b49eacc5c976181b492&mode=preview

I did avoid that line of code. The main resource I actually used to build the cursor is here:

I liked this dude’s walk through, I think the build is very similar minus the X-Y move trigger origins.

Oh, haha. Don’t mind my code then.

You changed the easing on the first Mouse X Action to “In Quad”. As soon as you change it back to “Linear (None)” it should work without any offset.

That guy in the tutorial seems to have changed some settings after taking the video too, you might want to check these aswell:

grafik

1 Like

THANK YOU CHRIS!
I have no idea how or why I even added that type of easing. happy new year.