Streaming live at 10am (PST)

Custom Code widget not displaying correctly

Hello Webflow community, I have been working on my website for the past month and a half now and i’ve hit a big road block

The page in question: Midnight Radio

Problem: Custom code embedded element will not display properly no matter what i do

Youtube video further explaining my issue: https://youtu.be/I8khX43yMo4


Hi @MidnightGaming,

In your custom code section, you are referencing jQuery version 2.2.4 two times with the same script when jQuery is actually already loaded by default ba Webflow to the latest version (3.5.1). i haven’t investigated further but this might cause conflicts.

Try kill those two scripts:

if (typeof jQuery == 'undefined') { 
  var i = "i";
  document.write('<script type="text/javascript" src="https://code.jquery.com/jquery-2.2.4.min.js"></scr' + i + 'pt>');
}

EDIT:

Also, it seems you are referencing the same scripts three times, one time in the head custom code section and a second time in before the end of the body tag and a third time in some custom code embeds in your layout. Only reference a script once may it be CSS or JavaScript.

1 Like

on my previous post, I was told to put portions of script into the head portion for it to work, Though it has been some time so ill have to do some experimentation. Thank you for your reply ill try them out :smiley:

Hey @anthonysalamin In my experimentation i have relearned that the jquery stuff is to do with the actual player. I ended up deleting that section and my player broke so i restored from a backup

Edit: I was able to get rid of one of the jQuery references and some of the double references of script sources

After getting rid of those things you told me to, The page loads quite a bit faster actually, thank you :smiley:
As for fixing the visual errors with the request widget, No progress sadly :confused:

Bump
updated read only link

bump i still need help fixing my issue

Bumping the post, Pls help