Streaming live at 10am (PST)

Custom domain issue: some people seeing new Webflow, while I'm going to old WordPress site

Yesterday we setup our custom domain so our Webflow site would replace our old WordPress site. Everything seemed fine yesterday as I tested nearly all of the pages.

However today when I type in the url it takes me to the old WordPress site.

But my other colleagues are being routed to the new Webflow site.

I cleared my history and cache and its still taking me to the old site but only on my laptop.

When I visit the url on my phone it takes me to the new Webflow site.

This is driving me crazy.

What is going on?


Here is my site Read-Only: LINK
(how to share your site Read-Only link)

Sometimes it can take up to 48 hours with hosters to change dns entries, it’s wierd that only your laptop shows the old page.
Did you all open the very same URL or did you maybe left out the www or used it?
Try switching between the non www and www versions as defaults in the hosting tab in the project settings

Sometimes using a different DNS than the one set by default by your ISP can help.

You can also try to flush your pc or mac dns cache. But I’m quite sure it should be propagated on your side by now.

1 Like

Thanks for your responses!
I think I was being a little inpatient.
Upon checking this morning the new Webflow site is appearing on Chrome, Firefox, Edge so it appears it just needed some extra time to transition.
Thanks for being supportive!!

1 Like

Thanks for your responses your information was so good.

1 Like