Streaming live at 10am (PST)

Custom font not loading on all browsers


#1

installed this font, which I uploaded first, everythings, looks oke. Until I change the font on the text and nothing happens. Have refreshed a couple of times, nothing.


#2

Hi @Aimanisms, Can you please update your post following these guidelines: http://forum.webflow.com/t/posting-guidelines-for-the-need-help-category/8094

In the meantime, you may want to include OTF, EOT, and WOFF font files for more reliable font rendering across browsers.

Thanks in advance! smile


#3

I don't know what any of those font types mean that you suggested. Looked at the link, how do I give u a share only link, I don't want this to be publicly shared here in the forum though.


#4

Hi @Aimanisms, this article goes over some of the other font filetypes that are useful for making sure your fonts work across all browsers. http://help.webflow.com/site-settings/fonts#custom-fonts

Keep me posted on your progress - if you still have trouble, let me know and I can try to take a closer look. smile


#5

They are web font files. TTF is mostly a desktop font file. When you only have a TTF file, you need to convert it to generate all the other files, but there are two very big issues with doing this:

  1. resulting files won't be optimized, most likely too big
  2. most likely, you will breach a copyright

So for your custom fonts, try to get them on a website like http://www.fontsquirrel.com/, so you're sure you have all the files and you don't breach copyrights.


#6

@vincent @thewonglv I followed the instructions and now it seems to work. Thanks for your info/help!


#7

Hi @Aimanisms, glad its working now! smile


#8