Streaming live at 10am (PST)

Deleting a collection field


#1

Hi,

I’m trying to delete multiple collection fields but I’m getting this error:

collection%20field

I have been searching for hours but I can’t find where it is being referenced from. The fields I am trying to remove are marked as “delete” in my products collection. I removed as many items as possible and I’m beginning to think it might be a bug.

Read-only link


#2

Before contacting Webflow’s support, follow this guide:

– Before being able to delete a collection, delete all bindings of purple elements in the Designer

– in the viewport: template page elements, and Collection Lists elements in static pages: all link settings must be turned to none

– in the Settings tab: elements can be bound to the Collection by a background image, a background color, a text color or a border color

vincent.polenordstudio.fr/snap/7j162.jpg

– in the Page settings: SEO, OG and RSS can be bound to the Collection fields

vincent.polenordstudio.fr/snap/ii716.jpg

– inside of every block of custom code (inside of a Collection List on static pages, or anywhere in a Template page)

vincent.polenordstudio.fr/snap/4r6wa.jpg

– How to browse all elements in the Navigator to spot purple ones? In the Navigator tab, select the Body element, keep Alt pressed while you press Arrow Down as many times as needed to browse all element. This will unfold the complete tree view of your site.

vincent.polenordstudio.fr/snap/0tir8.gif

– pay attention to the error message, they sometimes contain clues to where a binding is conflicting

– if you ever run into a case where you think all the bindings are deleted, but they are not, try to do a full version save of the site, by pressing cmd+shift+s in Mac or ctrl-shift-s in Windows. If that does not allow you to delete the collection element(s) then send an email to support@webflow.com.


#3

Hi

I went through the list and one field was actually referenced in the open graph settings. However I still can’t delete any of the fields in the collection, and I’m getting the same error. I did save the site but still does not work.


#4

It’s a tricky one.

If you’re sure that you’ve done everything, and if you have let a couple of hour pass, logout then login again, and still have the issue, contact support, they’ll do their magic refresh.


#5

Hi @SelectDesires, thanks for your message. I have refreshed the dependencies on the cms for the project, could you please try to delete the field from the projects collection, then delete the old categories collection?

Was it a single field that you had the trouble with? I did not see other fields labeled with OLD or Delete…

Thanks in advance


#6

Hi Dave,

The refresh seemed to fix it. I was now able to delete the 4 collection fields in the “Projects” collection and delete the “Old Categories” collection without a hitch. :slight_smile:

I am curious about what the refresh did and what caused the problem, I don’t want it to happen again :thinking: