Streaming live at 10am (PST)

Designer dashboard very slow, can't publish site, iOS interaction issues

Hi there,

Since the update “Resize the Designer canvas to preview site on larger screens” December 2, 2019 I have been experiencing two 3 issues:

1 - The designer dashboard is very slow, especially if I have to work on the interactions tab.
2 - Can’t publish the site anymore. After the December 2 update, the website was taking minutes to complete publishing, after a few days, I had to try many times until getting it to publish and now has been 2 days that I have been trying to publish it and nothing. The publishing animation keeps playing for hours, and nothing happens, and sometimes I get a timeout error message.

I’ve contacted the support, but they were not very helpful. They mentioned that a lot of things can affect the designer dashboard speed, which I already knew. But I have been using Webflow for more than 4 years already and I never had a problem like this before. And they didn’t mention anything about the publishing problem. The project the I am having problems was running completely fine until the December 2 update.

  • The third problem is that the menu I created doesn’t work on old iPhones and iPads, we tested on iPhone 7, and iPad 2 and pretty much all the interactions don’t work. But androids and iPhones from model 8 everything seems to work fine. (I think I found the reason why, but to fix it I need to be able to work with interactions without everything freezing every time that I try to make a change.)

I am not a developer, but the feeling that I have is the JS file/code is causing all the issues. But, I do know what to do and I hope some can help me, below the link to the website (not the lasted changes because I can’t publish them) http://painpod2019.webflow.io/

Thank you!

Hi went in to take a look at this site. do load slower then my sites, but yours is way bigger. I could not run it on iPad or the Web but realized that the links are pointing to the wrong location

And yes your interaction meny is really slow. tested one of my projects and that is super fast.
But as i said before much smaller then your project

It feels that Webflow have a problem with all pages and interactions. Like the project is to big, to many pages and interactions?? I have been playing with the project and somthing is wrong with WF.

They are pointing to a pages folder and that folder is not there
This is one of ypur links https://preview.webflow.com/pages/warranty-registration and the folder is not there

1 Like

Thanks Janne,

All the links will not work because I am exporting the website to host elsewhere.
I have been working with the crazy slow dashboard since the December 2 update, so I am almost used to it (Kidding).

My main concern is the interactions 2.0 on iPhones and iPads (Mobile view); they simply don’t work. Android devices seem to be working fine. I don’t know what to do to fix it, any suggestion?

I just noticed that if I turn the Interactions Legacy switch on, the slowness stops. So definitely it is something very wrong with the interactions 2.0 when active.

I need to make interactions changes, and every time that I change something in the interactions tab or click, everything freezes for 20s or 30s . I am going crazy here, it is impossible to work like that.

this is the message I get when I try to publish the site. 2 days already trying to publish it again!

@WebDev_Brandon I think you shuld take a look at this. As you can se it’s the interactions causing problems

1 Like

Hi @joaodecarvalho, first thanks for posting, our team is here to help and checking what may be the trouble.

I would also clean up unused styles on the site, having extra styles that are unused could result in performance degradation, I see there about 352 unused styles: https://share.getcloudapp.com/yAuLlRgQ, which is quite a lot, it is best to try and keep the number of styles low whenever possible. I do not think in this case it alone is the issue, but good to know to re-use styles as much as possible so that style count does not grow too big.

Webflow allows you to clean the unused styles on the Style Manager

Regarding the menu not working on older iphones, it is possible that the menu may work differently on different versions of iOS, a good place to check is on https://caniuse.com there you can type in the kind of css style property being used in the interaction to see the support on different devices and versions of OS.

Probably the biggest factor here though in the site publishing is the overall size of the site, I see 2187 styles, which is a lot of styles, we recommend to stay in the 200-300 range for best designer performance.

There is also a lot of image assets with over 2gb of files, so working in the site in the designer will be slower. If you can remove images and files from the asset panel which is not being actively used in the design or in styles, that will help with site performance in the designer.

Webflow does has publishing limits, if the site gets too large either with number of styles, overall site size, too many elements on a page or too many collection lists with lots of heavy collection content, then there can be these publishing timeouts which is an indicator that the site is approaching the project publishing limits or have hit the limit already.

I am helping to check with our team further on why the legacy interaction toggle is behaving like that and to help get the publishing issue resolved. I will get back as soon as I have an update.

2 Likes

Hi @cyberdave, thank you very much for the reply! Sorry for the late reply, I just got back from holiday.

I understand your point that the website is too big, images and styles. But I ONLY have performance issue when trying to work with interactions (When the tab is open), and this problem started after a Webflow update. It wasn’t something the slowly started to happen, one-day everything was fine, and the next day impossible to work. And if I turn the Legacy Interactions on, the dashboard runs normally. So looks like that it is Interactions problem, no?

About the issue with the tap not responding on IOS old devices, I believe that I found the reason why. The menu and some other interactions I created with the Mouse Hover function only and not Tap. So, looks like that some of the old IOS doesn’t recognise the Mouse Hover as Tap, as the new iPhones do. BUT, to fix it, I need to work with the interactions, and it is impossible right now.

If the reason why I can’t publish the site is that it is too big, Webflow should have a kind of warnings or something about it.

A week ago, I sent another email to the support with a video showing how slow the dashboard is when trying to work with interactions, but no reply yet.

I will try to clean the website as you suggested, but I am not sure if it will solve my interaction issue. The funny thing is, I opened the exported JS file in Dreamweaver to test it and to just perform a search in the code, the Dreamweaver started to run extremely slow. What if what is causing the issue is some kind of bug in the JS file?

Thank you for your help @cyberdave!

@cyberdave I forgot to mention that the website I am having problems is an updated copy of another project in Webflow. Both have pretty much the same styles and images assets.

The main difference between them is that the updated one (with the issues) has the new interaction style 2.0 (which I used to create the new mega menu style) and the older one doesn’t, only the legacy interactions.

I just tested the old project, and I can click on the interaction tap without slowing down the designer dashboard and also I can publish it without any issue.

So, it is just strange that two very similar projects in terms of styles and assets are behaving differently. And the only difference is the use of the interaction 2.0.

Thank you!

Hi @cyberdave good news! I believe I’ve found what was causing the problem. I removed about 700 styles, and it didn’t make any difference. But, I found out that I had about 50 pages with the new mega menu (made with interactions), which were not placed as symbols. Instead, each page was loading its own menu, and I believe that it was overloading the website with interaction elements (not really sure how to describe it technically). But after removing all the non-symbols menus, I finally managed to publish the website, and I am not experiencing the slowness when the interaction tab is active. I will let you know if I have the same problems again! Thanks for your help!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.