Streaming live at 10am (PST)

Designer goes blank on safari as soon as an element is clicked


#1

Hi,

I have been working on this site using chrome. The live site works fine on chrome but not on safari. I read somewhere that I just need to open the designer on safari and make changes there.
I tried that but as soon as I click on an element, the whole screen goes blank.

Safari is also up to date.

Thanks in advance.


Here is my site Read-Only: https://preview.webflow.com/preview/pickleweb?utm_source=pickleweb&preview=53d318177758c9d9d8fb2a7074cdd021
(how to share your site Read-Only link)


#2

Hi @Mohammad_Shakeb,

Are you still having an issue with this?

I’ve loaded your live site

pickleweb.webflow.io

and it’s showing fine for me on Safari and Chrome.

The screenshot you show has webflow.com as the domain in the web address bar, is it the designer or the live site you’re having an issue with? I’ve tried the designer in a few browsers too and seems to work OK.


#3

Hi @magicmark

Thanks for checking it out.
Yes, I am still having this issue. The live site looks like this in Safari:

Both. In some thread about the same issue, someone suggested opening the designer in safari. I am not even able to do that. It goes blank as seen in the screenshot attached in my first message.


#4

I am not super familiar with Safari, but I experienced a similar issue and it was due to a Chrome Extension.

My suggestion would be to try safari without extensions, cleared cache etc.


#5

I tried to open it in private mode also, didn’t work.


#6

Does sound strange.
As @Thomas_92 suggested, remove any extensions that might be running, clear your cache and try that.

I’ve pinged @Brando in too who will be able to follow along. You can always email support@webflow.com directly for what might be a quicker solution.

Sorry I can’t help more than this.


#7

Okay. I will try clearing cache.
Thank you.


#8

Hi @Mohammad_Shakeb

Thanks for posting about this — that definitely looks odd. I’ve opened your site in Safari on this end, but I’ve not been able to reproduce the crash. I’m testing on macOS 10.13.6 with Safari 12.0.

Can you please try the following:

  • Try the site once more in incognito mode with all extensions turned off
  • If the problem persists, please take a screenshot of your Console and send it to me

Could you also please try updating Safari to the latest version? It may be that the issue doesn’t happen on more recent versions.

Thanks in advance!


#9

10 posts were split to a new topic: Selecting element and then the style panel crashes designer


#10

Hi @Brando

I am sorry for not replying sooner. I have tried private mode and there is no extension enabled. Here is the screenshot of Console as requested.


#11

Hi @Mohammad_Shakeb

Thanks for that screenshot — this definitely helps when troubleshooting.

I’ve reported this issue to the team and we’ll investigate to see what the issue is. To determine the severity of this issue — are you blocked only in Safari, or Chrome as well?

​Thanks in advance for your patience!


#12

Thanks for helping me out.

I am blocked only Only in Safari.


#14

I’m experiencing the same issues on Safari 12.0 (macOS 10.14).

I’m using Adguard as a system-wide ad blocker and that has caused weird issues in the past.
Extensions installed :

  • grammarly
  • honey
  • last pass

#15

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.