Streaming live at 10am (PST)

Designer performance


#1

I’ve been having major issues with using the designer for several months. I have a large site with CMS… the issue started out of nowhere, but now I don’t remember what it’s like to use the designer without lags and insane slowness. This is becoming a major issue for me — I can hardly make changes to my website anymore…

I truly hope this issue is not because of the size of my site. If so, we will have to move to a different platform to support our growing online business.


Here is my site Read-Only: LINK
(how to share your site Read-Only link)


#2

Hi @wethebirds, thanks for your post, I would also recommend to check that the browser is running the latest updates, and to see if there are any browser extensions loaded that might be conflicting with the Webflow browser code.

A good way to check if browser extensions are conflicting, is to open the browser in Incognito mode (in Chrome) or Private Window mode (in Safari) and reload the site in the designer.

It would also help to know which site is having the slowness issues, I am happy to take a look to see if there are any in-designer optimizations that can be made to help make things run smoother.

As a general rule:

  1. Keep browser up to date
  2. If using browser extensions, open the site in the designer using Incognito Mode
  3. Delete unused styles on the site (clean up styles from the style manager)
  4. Delete unused symbols
  5. Limit the use of too many video widgets or background videos placed on a single page to a minimum
  6. Optimize images before upload to Webflow: https://webflow.com/blog/how-to-boost-your-sites-performance

If you do not wish to share the site details here, you can also sent that via our contact page at https://university.webflow.com/contact

Webflow has a started a performance team to tackle some of the recent performance issues that have been reported, more information to come on that effort when available.


#3

Your last two lines are the most importend for me Dave, We are all struggling with bigger sites at this moment.


#4

Hi @Koen, totally understood. A big effort is underway to make sure that Webflow performance levels provide a good experience in the designer.

Constructive feedback about the performance on individual sites is helpful to share with the team, feel free to send that to https://university.webflow.com/contact.


#5

I have encountered this issue as well.

Particularly on seeing ‘waiting on pubnub’ stuck on the cue on the loader which cause browser to crash on multiple instances.

I Shared this with the developers.

To better resolve this I performed the following.

1. Create a new browser profile instance in chrome.

  • Go to chrome://settings/
  • Manage Other People
  • Click on Add Person
  • Give it a name like ‘My Name - Webflow Only’

Note: For this chrome instance, do not ‘log in to chrome’ nor ‘sync chrome user’ in chrome settings. Your browser might ask you to, but don’t.

Note 2: Only use this browser instance only to log into webflow. Do not log into anything else.

2. Open new browser profile instance in a new window / system process.

  • On your upper right corner of your chrome window, you should see your chrome instance Avatar/User dropdown button. Click on it to expose your Chrome user profiles.
  • Now click on theprofile you just created such as ‘My Name - Webflow Only’ to open a brand spankin new chrome instance with fresh cookies.
  • Do not sync your browser to log into gmail (or anything else) for that matter in this browser profile (yet).

Note: this is similar to incognito mode, the main difference is that incognito mode inherits some of the privacy and cache settings of your main browser instance of which the incognito mode was opened from.

3. Disable services and auto clear cache and temp files in new browser profile. - DO NOT perform on your regular browser profile

  • On your NEW chrome profile instance, go to chrome://settings/
  • Select ‘Advanced ▼’ to expose advanced settings, and scroll down to ‘Privacy and security’ section.
  • Disable ‘Use a web service to help resolve navigation errors’ - this is enabled by default
  • Disable ‘Use a prediction service to help complete searches and URLs typed in the address bar’
  • Disable ‘Use a prediction service to load pages more quickly’
  • Disable ‘Protect you and your device from dangerous sites’
  • Disable ‘Automatically send usage statistics and crash reports to Google’

note: disabling these services is NOT recommended for normal browser instances.

  • Auto Clear cache on exit:
    • click on ‘Content Settings ►’ then click on ‘Cookies ►’
    • Choose ‘Keep local data until I quit my browser’

4. Export HTML/CSS/JS/ASSETS into zip and then delete deprecated content and clean up css.

  • Skim your html / css … exported files on your PC. Usually you’ll find things you should delete right away.
  • In your css file, you might notice lots of duplicate classes such as ‘div 1’ ‘div 2’ ‘div 4’, that have identical attributes. This is ually an easy clean up by retagging div 2/3/4 as div 1 in your designer project, then deleting div 2/3/4.
  • also delete deprecated CMS labels from CMS collections
  • delete deprecated assets/pictures from assets panel
  • delete deprecated fonts from your settings > fonts menu
  • if you make any oppsies in designer mode you can revert back into an achieved instance and/or refer to your exported assets html+css for easy rebuiding

5. Compare Designer Performance to new Profile performance.

  • Is Designer Loading faster in new browser profile?

    • if so, your primary browser may have conflicting cookies and/or add-ons.
    • (advanced) By comparing inspect chrome dev tools reports, between the 2 instances ‘https://developer.chrome.com/devtools’, you can better pinpoint the cookies, cache files and or plug-ins that are causing webflow to hand in your primary browser instance. If you are an advanced user, this is handy anyways. I usually inspect user Network tab first, which is where I usually diagnose 90% of issues web set-site related errors.
  • Is Designer Loading NOT loading faster in new browser profile?

    • If so, maybe your network/firewall/vpn or other related network issue is the cause of your webflow designer pooping out.
    • If so, is your ANTI VIRUS software preventing webflow from loading assets into designer? Did you have a recent system or antivirus/malware update?
    • If so, you may have throttling issues on your PC. Check (resource Monitor on PC / Activity Monitor on Mac) CPU/RAM/DISK/NETWORK monitor while using webflow. Do you notice any unusual spikes in CPU activity? Is RAM chocking out? Is DISK stuck at >98% utilization / Stuck in ‘hdd pageswap mode’? Is Network throttling in Chrome or Browser (sending xkb but reciving less kb in return)

Use your regular browser for normal activities and to verify how your page is rendering.

Use new webflow only profile to log into webflow, when your normal browser is giving you issues with page load in designer.


#6

Here is my read only link:
https://preview.webflow.com/preview/wethebirds?preview=60549f59a7c24afe05e034ec76e8b4d3

I always use incognito mode - as was recommended by the webflow team. I can work on deleting unused styles and symbols.

We have an image-heavy blog website (which IS our business) and I am concerned that webflow cannot handle our growing CMS-based publishing.

Its very frustrating to be experiencing this ridiculous slowness/lag in the designer. I LOVE webflow and do not want to switch to anything else, but I am frustrated that there seems to be a threshold on how big your site can be in order to use this platform. I can’t find any information regarding limits on size of sites for webflow, but I have a suspicion that the size of my site is causing this issue (which indicates that webflow cannot handle large sites / CMS). I hope I’m wrong…


#7

If you agree to any of the statements below, try new browser profile instance with network settings on original reply.


Yes or no:

Do you see a loading state on “Waiting for pubnub.com…” in your browser cue? in the lower left cornr of chrome when you load your project?

image

Yes or no:

Does your ‘loading screen’ take longer than 10 seconds?
image

Yes or no:
Does Initializing panels get stuck, or take longer than 10 seconds to load?
image

Yes or no:

Do you encounter a page unresponsive crash after waiting 30 seconds for project to load OR for browser to load assets from pubnub?

image

Yes or No:
Do your assets take longer than 25 seconds to load in assets manager?

image

Yes or no:

When reloading webflow/designer, it takes over 15 seconds to load


#8

Thank you so much for this detailed response. I have followed your instructions on creating a new browser profile and will report back!


#10

Does your webflow still crash on your new profile instance?

if NO, then most likely you have conflicting cache and/or browser addons on your original browser profile.

if YES, try the steps below:
If webflow is still sluggish, your dynamic components might cause it to be laggy.
a. Remove Maps component and replace it with a static image.
b. Remove social media components and replace it with static image, then link them directly to your social pages.

If removing components improved your webflow designer experience, that means that webflow is stuck loading things in the background. Particularly if components are in a symbol.


#11

Hello - thank you for the detailed suggestions!
Update: I created a new browser profile and this has helped tremendously.


#12

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.