Streaming live at 10am (PST)

Device management


#1

I'm at a a loss now. I've changed all elements to appear nicely on devices and when I've uploaded site to server it looks like rubbish. Help!!!!

Live site: http://www.balmainwharf.com.au

Webflow: https://preview.webflow.com/preview/balmainwharfapartments?preview=52980305e7ebd38473797bf567daecb3


Here is my public share link: LINK
(how to access public share link)


#2

I don't exactly see what is wrong? Can you point to the rubbish?


#3

Hi @dzgraphicdesign
Id get rid of the height values in your sections and your containers. you should always use auto where ever possible and let your content define the heights of your elements. Use padding to adjust spacing at the top and bottom of your sections. Also refine the Headings sizes on mobile. Try and tighten everything up, logo smaller, drop the icon on the phone number etc. Also make your padding consistent.

Looking good though

Sveky


#4

Hi Sveky,

Thank you. I'm still learning best practice. So to clarify, I should use a div first then sections etc. Then create padding on the div for each device?
I find it tricky not using heights, unfortunately this whole site has them defined in most places due to set up but I'm getting better at learning the optimum way to do this moving forward.

Regards
Deb


#5

Yeah i noticed looking through the elements. Most things have heights and like you said its a pain to edit all of them. There are a few issues with the way its structured . Id start on desktop removing all the height values from sections and containers, column etc. Put your logo into a link block and drag an image into it rather than having a background of the logo in a column. Id recommend watching a few of the tutorials as well.

If i were you id clone the site and make a new build.

Sorry maybe a webflow staff member can give you some more advice, i got to get back to work :smile:

Cheers
Sveky


#6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.