Streaming live at 10am (PST)

Disable URL activation at certain places (like the slider arrow)

#1

Hey!

I’m trying to figure out how to make a slider with images in the background pulled from CMS that is also connected to a URL. The problem arises when you click arrow left/right, the URL activates and takes you to the designated landing page.

A workaround is that I don’t use images as backgrounds, and put the image property into the slider, and connect it to a URL; so it activates only when you click the image, but then you’ve got the scaling problem with imagery… I see that AirBnB does it with image background, yet when you click the arrow it doesn’t take you to the landing page.

Here is my site Read-only link

Please check under “Slovenia Explore”

Live page

Thanks!


(how to share your site Read-Only link)

#2

Does anyone have an idea how to solve this?

@cyberdave

#3

Hi @DomenVi,

​Thanks for getting in touch. I have checked out the site from the forum post, it looks like you have the sliders nested inside of a link block, so that is why the nav links are not working, it is because of the whole slider being nested inside of a link block.

​The solution would be to create your slider and put link blocks inside of each individual slide, you can set up your link blocks to have 100% width and height and then apply a background image to each individual link block that is nested inside of a slide instead.

​Once you do that, the slide navigation will work and when clicking on a slide the link affixed to the link block on each slide will open normally.

​I hope this helps

#4

Ah, so simple! Thanks so much Dave, now I can continue with my work!

Domen