Streaming live at 10am (PST)

Disabling link animation for Current state

Is there a way to disable my mouseover animation for the Current state?

(Hover effects only work if you click into the designer and back out into preview mode for some reason)

Preview Link

hey,did you sorted it?..have the same problem here

What’s your problem specifically? I can’t access the original read-only link and I’m not sure I understand the question enough to give a solution without an example of sorts.

if you hover the home page on curent status change from white to red, in an interaction that i dont want to play on it when is on "“current”.

Thanks for replying Mike

Just a heads up, the link you provided doesn’t work—however I was able to access the correct staging URL by grabbing the end of the URL (linked below):

http://nicolas-awesome-project-28414a.webflow.io/

That said, can you provide your read-only link so I can take a closer look on how this is built?

https://preview.webflow.com/preview/nicolas-awesome-project-28414a?utm_medium=preview_link&utm_source=designer&utm_content=nicolas-awesome-project-28414a&preview=55c7e5684f9b0a3c3b64e800ff9f5ede&mode=preview

here yoy have it Mike,i’m learning and your help is much appreciated!!

Was there a solution for this? I use a symbol for my nav bar, so I use it across multiple pages. I would like to eliminate the animation for the current page. However, even why I’m on the current page (and Current appears in the Selector) any changes to animation impact every instance.

Essentially, looking for a way to turn off animation for the current page, but leave it for other pages in the nav. Here is the read-only link: Webflow - Rose Farm

Super odd, the nav animation doesn’t seem to work in that read only mode…here is staging so you can see it working: https://rose-farm.webflow.io/

Thanks!

@nicola_cuomo - My apologies for missing the reply on your last message, but the current combo class is inheriting the hover style from your main nav link so you’ll just need to override the effect on an instance of the class with current applied to it:

@John_Jackovin - In your case, you’re actually using a hover interaction (not the normal :hover pseudo class) so it’s a little different than the original situation. Unfortunately I’m not sure if there is a way to make this happen without some custom code to manually override the behavior when the element is using the current combo class.

Hopefully I’m wrong and there is a way to make it happen but I wasn’t successful in my attempts :slightly_frowning_face:

Right, I’m not using the standard hover because I have the bee flying in and I want to impact other components. It’d be sweet if there was a way to keep the current selector selected and make mods that only impacts that instance of the animation. But alas.

mike thanks for answering, on that project i fixed it with some custom code…nut is cool to know there is a combo class …actually i could have taught that!!!..thanks!!

Thanks mate…i appreciate…i didnt know i coud put a combo class like that…super!!!