Streaming live at 10am (PST)

“Display: none” doesn’t work in interactions


#1

Hi guys,

I’m trying to create a custom mobile menu.

I’ve put it all together, no problem. However when I set its initial appearance to display: None in the legacy interaction menu (so its hidden on page load) It doesn’t seem to work.

What am I doing wrong? Any help greatly appreciated.

Read only link: https://preview.webflow.com/preview/stephane-lustig?preview=f7828b14b24de8ab02b1a23b55cf9117


Click interaction wasn't working – removing unused styles and reloading Designer deleted interaction
#2

Your mobile menu is not visible.


#3

Hi there, thanks for the response.

Thats strange, it still shows on mine.

Anything i’m doing wrong?


#4

displaying when… in Preview or Design Mode.

The screen shot is from Preview…
in Design Mode - yes it is visible.


#5

I had displayed in preview, and on the live link: stephane-lustig.webflow.io

Still an issue.

Any advice, greatly received.


#6

Confirmed… this is from iPhone.

Heading to doctor appointment. Back in a few.
Will look again when I return.


#7

Appreciate the help.


#8

Pretty sure i’ve figured this out.

Within the visibility section in Div Block Settings, I had the menu turned off for desktop.

I turned it back on, and changed the display settings to none within the styles tab.

This seemed to do the trick and fix the problem.

Not sure if it was a glitch causing this, but yeah the above workaround has seemed to do the trick.


#9

awesome. I missed that one !


#10

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.