Streaming live at 10am (PST)

Disqus doesn't appear on the publish site


#1

Dear guys,
I have followed the intructions to put disqus comment plugin to the website but it doesn't appear on the publish site. And I really hope that you guys can help me with that.

I have copied the code from this url on disqus: https://myblogbebe.disqus.com/admin/settings/universalcode/

And then put the code into an HTML embed and place it on the page.
Here is my testing website (to make it simple, the website has only one element - the disqus embed code): https://webflow.com/website/thangs-testing-site?s=thangs-testing-site
Here is the screen shot when I publish it.

Please give me a helping hand. Thank you so much.


#2

Can you please provide your site's read-only link? Thanks in advance :smiley:


#3

Here it is: https://preview.webflow.com/preview/thangs-testing-site?preview=9bb7ee4d49cde47d685a4a2d2c10745f
:smile:


#4

Any help? Please.
Thank you so much. :smiley:


#5

seems like you have a syntax error in your custom code. try copying your code snippet again from disqus.

you can see the error in your DEV TOOLS:
https://developer.chrome.com/devtools

hope this helps :slightly_smiling:


#6

Thank you a lot.
I did copy the code from disqus, here how it is:

<div id="disqus_thread"></div> <script> /** * RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS. * LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables */ /* var disqus_config = function () { this.page.url = PAGE_URL; // Replace PAGE_URL with your page's canonical URL variable this.page.identifier = PAGE_IDENTIFIER; // Replace PAGE_IDENTIFIER with your page's unique identifier variable }; */ (function() { // DON'T EDIT BELOW THIS LINE var d = document, s = d.createElement('script'); s.src = '//webflowblog123.disqus.com/embed.js'; s.setAttribute('data-timestamp', +new Date()); (d.head || d.body).appendChild(s); })(); </script> <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>

And then I put the code exactly into an HTML embed and place it on the page. I didn't change the code at all since I have read this post saying that I don't need to edit the disqus code: http://forum.webflow.com/t/adding-disqus-to-a-blogpost-template/20556/4

I tried copying the code from disqus again and again as you said but it didn't work. I have use the DEV TOOLS and saw the error but I don't know how to fix it.

Do you have any further advice? Thank you so much. :slightly_smiling:


#7

Notice in your custom code that there are variables that say

PAGE_URL and PAGE_IDENTIFIER

it seems like you're missing those variables. Please re-read the instructions on disqus to learn how to install that widget.


#8

take off the <div id="disqus_thread"></div> in the code and give the div block that the embed element is in the id=disqus_thread

This is how I got it to work for me. Let me know if it worked =)


#9

You're my hero. :smiley:
Thanks a lot for your reply.
I will try and let you know if it works.


#10