Streaming live at 10am (PST)

Disqus is not working on my Blog Page

Hey All!
I keep getting the disqus error message on my Blog Posts that disqus is unable to load. I’ve done both the Disqus and Webflow Univ install tutorial and both have not worked. Below is my Share link, any advice would be so grateful!

Welcome to the community @mpVagaroflow!

It looks like your codes identifier variables are still commented out (highlighted below):

Uncomment this block of text and replay the PAGE_URL and PAGE_IDENTIFIER variables with dynamic fields from your CMS content. Assuming the ‘Post ID’ is unique between each blog post, you can use that for your PAGE_IDENTIFIER and the slug for your PAGE_URL.

Let me know if you run into any issues :+1:

Hi Mike!
Thanks for your response!
So I did as you said (see screenshot), and it’s still not working.

I looked at the Disqus tutorial and they mentioned that i may have an incorrectly-formatted Javascript variable, that I should use an absolute URL for the “this.page.url” variable. Tried that and still it does not work. Any Suggestions?

Thanks Mike!

When I set up Disqus on my test project (https://lets-disqus-webflow.webflow.io - shown on each of the blog posts) here’s what I included for my HTML Embed element:

image

Obviously if I had my own unique ID I would have included that, however I figured the slug would be unique given I only have a single blog showing comments.

The front-end is showing the appropriate comments however I’m noticing that there’s an error in the console (shown below) so I’ll need to do some more testing to see if I can fix it:

image

1 Like

Thanks Mike, I will also try what you did in the HTML Embed element :slight_smile: .