Streaming live at 10am (PST)

DNS and Browser problem (This site can’t provide a secure connection)

Can some please help me with this !
Ive updated my DNS record and CNAME as per instructions from the webflow hosting tab, which all seem to be working fine.
I have publish a test page from webflow designer and its telling me all published ok.
Now when i browse to my domain it just errors and tells me This site cant provide a secure connection !
Ive spoken to my domain hosting company and they are telling me it the site host that causing the problem ! so now im stuck , and cant see a way of contacting webflow for assistance.

thanks stuart

Have you set your www domain to default in the property’s

Yes as far as I’m aware

It’s acting strange because if I try my website www.techsite.ltd from my pc i get a ssl error but if I try it from my iPhone it works as long as I’m not on my WiFi at home !

Sounds like the dns servers need more time to update

Yes I was thinking that, if I do a whatsmydns check its showing the correct settings from the webflow project hosting tab.

But option 1 which it recommends is showing issues detected.

Not sure what else to check to be honest !!

Hi Stuart,
Im having the exact same problem as you, what solved your problem?

My website works if i go to www.limpinwoodlodge.com.au, but if there is any http or https infront of that I get that message. My big problem is that every site or google listing automatically adds http to the front of any link clicked.