Streaming live at 10am (PST)

Does Webflow have IPv6 yet? 1and1 won't let me point to Webflow without it


#1

I am trying to point a custom domain from 1and1.com to a Webflow site. 1and1 requires an IPv4 and an IPv6. In an older thread, I see where Webflow does not support IPv6. https://forum.webflow.com/t/ipv6-and-a-records-on-1and1/23965

Is this still the case? If yes, that's a problem because 1and1 won't let me save the form without entering an IPv6 number.

(And I'm kind of stuck with 1and1 -- it's a website I'm doing for a friend and not a domain I own.)


#2

I am having the same issue! Did you get anywhere with this?


#3

Hi @Linda and @Lyndsey_Whitefield you should be able to add IPv4 A Records according to 1and1's help documentation: https://help.1and1.com/domains-c36931/manage-domains-c79822/dns-c37586/change-your-domain-s-ip-address-a-record-a599296.html


#4

@Lyndsey_Whitefield @Waldo
After a lot of trial and error and several calls to 1and1 support and help from @Dave (did I get the right Dave?) here at Webflow, I finally got it to work.

For my sake and to hopefully help others, these are the correct steps as much as I can recall. @Lyndsey_Whitefield let me know if these steps work for you, so I know if I missed anything. Best of luck!

  1. When you are logged into 1and1, go to the 1and1 Domain Center (my.1and1.com/domains).
  2. There will be a table with headers for domain, status, expiration date and actions.
  3. Click on Actions (the three vertical dots) and select Advanced Settings from the dropdown.
  4. It will take you to a page with your main URL listed at the top, a section for Basic Settings, and accordion dropdowns for Subdomain Overview, Domain Contacts and DNS Settings.
  5. Next to the DNS Settings headline is an Edit link. Click it.
  6. In the Name Server Settings section, leave “1&1 name servers” radio button selected.
  7. In the A/AAAA and CNAME Records section, click “Other IP address” and enter one of the two Webflow IPv4 addresses. Leave the IPv6 field blank.
  8. Click Save. (If it won’t let you save because you left the IPv6 field blank, call 1and1. For me, the form was behaving as if IPv6 was a required field and wouldn’t let me proceed. I don’t know if 1and1 changed anything on their end, but the next time I went back (~24 hours later) I was able to just enter the IPv4 and save the page.)
  9. Create a subdomain with “www” (e.g., www.yourwebsitename.com). Check out this Help center article for detailed instructions: http://help.1and1.com/domains-c36931/manage-domains-c79822/dns-c37586/enter-a-cname-for-your-subdomain-a643600.html
  10. Go back to the Advanced Settings overview page.
  11. Expand the Subdomain Overview section.
  12. Click on the subdomain URL and more information will appear below it.
  13. Select Edit DNS Settings
  14. Select CNAME from the A/AAAA and CNAME Records section
  15. Put proxy.webflow.com as the Alias and save.
  16. Tip: If you happen to click into Edit Destination from the Subdomain Overivew section, the target should be set to Webspace -- don’t select Redirect (a mistake I initially made).

Now, I don’t know if this next part is required, but the 1and1 CSR told me to do it, so I did. He called it setting up a glue record:

  1. Set up two more subdomains with the format of ns1.yourwebsitename.com and ns2.yourwebsitename.com and follow the same steps 9-16 above.

Settings in Webflow
1. Add your three subdomains (www, ns1 and ns2) to the Custom Domains section of the Hosting panel. They should connect. (If they don't, I missed something here in my directions). Select one of them to be the default.
2. You should now get your site to show whether someone types www.yourwebsitename.com or just yourwebsitename.com.

Note: I tried adding my naked url (e.g. yourwebsitename.com) as a Webflow custom domain but never could get it to connect. I may still have a setting messed up somewhere but the method above got me what I needed).


Possible issue with setting up 1and1 domain on webflow
Hosting with 1and1
#5

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.