Streaming live at 10am (PST)

Domain 404 Error with and without WWW


#1

Hey,

So i've uploaded a custom 404 page to my site, it redirects fine when you search for anything after my domain. (.com/notreal redirects to 404) But my issue seems to be this:

www.mydomain.com loads my website fine... but

mydomain.com is directed to the standard webflow 404.

My concern is that many people have grown accustomed to not typing in the www. and I do not want my visitors to see the webflow 404 and be confused.

I searched for a fix on this topic but i don't believe I found it.

Let me know how I can fix this, or if I should contact support for the fix of this issue.

Thanks in advance!


#2

Hi Dennis, is "mydomain.com" added as a custom domain in your site? You should add a DNS redirect to point users to the WWW version instead of showing your custom 404 page.

Here is how DNS simple does it: http://support.dnsimple.com/articles/redirect/

Godaddy: http://support.godaddy.com/help/article/422/forwarding-or-masking-your-domain-name


#3

Hi brryant,
I can not get this address http://getkeyboarder.com/ to properly redirect(godaddy) to http://www.getkeyboarder.com/
I tried your link and some other suggestions, nothing works for us. (i have waited 48h for each change before complaining )
Can you help?


#4

Hi @lukap3rcic , can you send me a PM with your Webflow site domain name? I can check your setup in Webflow and what is reported in DNS tracking, and then give you an update, what you need to do. Cheers!


#5

Hi @lukap3rcic, looking at the dns tracking on your website, I see you have one of the Webflow A Record IPs setup and pointed at Webflow as per the instructions at:

http://help.webflow.com/custom-domain-setup

However you still have A Records in your Domain name settings, pointed at some server that is not Webflow:

184.168.221.17

You should remove the A Record with IP 184.168.221.17 and make sure the only two A Records for your domain are:

54.225.115.32

54.221.217.126

Check that, update changes and then wait for DNS propogation (it should not take long, maybe a few hours) and then check again, it should work once those DNS A Records are fixed at your DNS settings provider.

Cheers, Dave


Submitted URL seems to be a Soft 404
#6

I have set it back, then tried again some of the suggestions for how to redirect page, but i still get webflow 404 site, when visiting
getkeyboarder.com , without www.
(i always wait 48h to be sure that dns changes takes place)
Please advise.


#7

I am having the same issues with my website Dave, dsservicesuk.com is not working but www.dsservicesuk.com is working...what do I need to set up for both to work


#8

Hi @lukap3rcic and @Paul_C, I am just going through some posts on the forum, and I noticed both of your comments. It seems those domain issues were resolved through a support desk ticket, so I am just checking to make sure that there is not any issues remaining concerning your domain dns setup. I checked out both sites and the domains appear to be working good smile Let me know if you need any further assistance, I am here to help smile Cheers, Dave


#9

Hi @cyberdave

Same problem here. You suggested lukap3rcic to remove one A-record and to have only two (yours). At my domain provider I have also three IP addresses. But the problem is I can NOT remove it. Contacted domain name provider and got a reply it shouldn't be moved. It's also locked for doing so.

And yet, it seems that DNS are working, because even when updating my site on subdomain (dva12.webflow.com) it returns 404 error. And it's your, webflow, 404 error page. So something must be wrong on your side? I think...

My other problem. I can not publish my site on my own domain dva12.si. Every time I publish it get published on dva12.webflow.com.

Can you help with that?


#10

Hi @dva12, thanks for your update. I believe there is a support ticket also on this case, which I am also looking at. The A Record for the localhost should be ok. I am checking into this. Will get back soon with more info.

Cheers,Dave smile


#11

Hi Dave,
URGENT - we are having the same problem. We are getting the 404 even after pointing to our custom domain. Can you please help?

Our site is : hyrecar.com


#12

@hadipa - did you republish your site to your custom domain name?


#13

Ah - just did and it worked. I didnt know I had to. Thanks!


#14

HI guys, I was having the same problem as initially described at the beginning of this thread. By reading the answers I was mislead into thinking that I had to edit the DNS settings with my domain provider, and so I did, but eventually it turned out that it was not a problem on that side. When adding a custom domain to the 'site settings > hosting' in Webflow, you are supposed to add both mydomain.com and www.mydomain.com, so the site can be published on both at the same time. With this changes, the site works with both the www and non-www domain set.


#15

Just an update to this old thread, we have updated the IPs for the A-Records.

For more information on this, please refer to this article: http://help.webflow.com/article/where-do-i-edit-my-dns-settings


#16