Streaming live at 10am (PST)

Double setting up an SSL custom domain


#1

Hi webflow,

Running into an issue setting up a custom SSL domain name. It was purchased through dreamhost.com which is also currently hosting the old site www.arrowgtp.com. We are trying to make arrowgtp.webflow.io to be the new default site, but we are running into issues. I adding the A records fine, but the CNAME record is not working, and we get the following error message:

The message reads: You already have a record for this name. You can't have a CNAME and any other record on the same name...

dunno what to do next. There is also no place to add a TTL in the 'add record' section.

Please help! Thank you!

R


#2

Could you provide a screenshot of the current domain DNS records?

Something like this:


#3

Here you go...

This:

And this:

And finally, this:

Yeah, no idea what I'm doing, really...

¯_(ツ)_/¯


#4

You might need to transfer your domain name elsewhere before you can edit the DNS records. Dreamhost seems to prevent you from changing these because you have an existing hosting plan with them.

The first non-editable entry and last "www" entry needs to be changed to the IP address of Webflow servers.


#5

ok, I'll look into doing that. I think that webflow had a few recommended registrars. I'll check those out first...

thanks :slight_smile:

R


#6

I'm currently using Google Domains. You can also try Namecheap.


#7

argh...transferring domain names takes sooo long.....argh...


#8

Thank goodness you only need to do it once, to a good domain name registrar. From there you can just point to wherever.


#9

k, done....now what do i do? I don't know what to keep and what to get rid of?

here:

and here:

and here:

and here:

yeah, this is all quite out of my depths...

R


#10

Under Custom resource records,

  1. Delete all types with value "A" or "www".

  2. Follow step 2 here https://help.webflow.com/article/how-to-enable-ssl-on-webflow-sites

    or insert these two entries:

    arrowgtp.com	CNAME	proxy-ssl.webflow.com
    www		CNAME	proxy-ssl.webflow.com

#11

yay!!!! it worked!!! thank you!!!!!!

arrowgtp.com

R


#12

I am having trouble with this through GoDaddy. Any Advice ? I am getting www.www.domain.com when it shows everything seems to be right after I enable SSL in Webflow.

Thanks,

Jibby


#13

@JibbyFlow Please create a new thread and post the same things that rchrdnsh did above, otherwise I am unable to help.


#14