Streaming live at 10am (PST)

Drop Down Sub Menu with images doesn't stay open on mobile

I created a custom drop down menu and something seems to have caused an override which is preventing my drop down sub menu with the images from staying open when you click in in mobile.

If you press the drop down, the sub menu should open and you can access the links there. It works on desktop when you resize and hover over, but doesn’t work on mobile when you press. There, it just goes straight to the WORK page.

public link

:

https://preview.webflow.com/preview/angelalei?utm_medium=preview_link&utm_source=designer&utm_content=angelalei&preview=9ebf3091bd7be276da2715df0ce1a1cc&mode=preview

Any advice on how to get this to work?

Thanks!

Hi @angcanada,

First off cool site.

I would say uncheck the open on hover checkbox first. See if that works.

Secondly, you really dont have a custom dropdown menu if you are using the stock nav menu element. That is prebuilt and not really designed for the actions you have.

Also keep in mind that when using a dropdown as an actual link on mobile, it will ALWAYS default to the link FIRST before the dropdown action. This is where creating an actual ‘custom’ interaction dropdown would be used.

Hi @WebDev_Brandon

Thanks for your comments!

I probably have to do a real custom drop down then. When I uncheck hover, it does it for all breakpoints, so that doesn’t work for desktop view.

However, when I don’t link WORK to the WORK page, and leave it as a drop down, the sub menu still doesn’t stay open on mobile.

I used the same concept for this site:

https://preview.webflow.com/preview/buildinginspector?utm_medium=preview_link&utm_source=designer&utm_content=buildinginspector&preview=4c0747b5adb4dd276f698cda41a12a1e&mode=preview

and it works fine! sub menu stays open on mobile. So maybe I’m thinking the whole images/link thing that I’m doing is causing a conflict.

Thats a probability as well.

When you start adding images to a prebuilt nav you may have issues like you are. It might be better to build your mobile nav the way you want to and keep the desktop as it.

Yeah, I’ll try to tinker around a bit more, but I might end up having to do that. I used way too many css styles in the image hover overs. Maybe have to redo from fresh. These styles carry over from where it appears in other pages.
Thanks again.
If anyone else has any suggestions, that would be great.