Streaming live at 10am (PST)

Dropdown Nav - long links not flowing onto line below

Hello.

I have seen this mentioned twice on this Forum, once in 2016 and the other time in 2017. The solution suggested is to force the CSS by adding the following styles to control things

.w-dropdown-toggle {white-space: normal;}

I have done this but it still isn’t fixing the issue (I also tried white-space: normal !important; - doesn’t work either)

Interestingly, when I un-check the lower mentioned element of 'white-space:no-wrap; (in re highlighted box) it fixes things. Even though it is listed as being struck through.

Can anybody tell me what’s going on here and how I can control it? Seems I can’t turn off the Webflow default setting of .w-dropdown-toggle{white-space:no-wrap; } (I don’t really want to put line breaks into the navigation.)


Here is my site Read-Only: https://preview.webflow.com/preview/mcveagh-fleming?utm_source=mcveagh-fleming&preview=1adc79e9ed5422ce52c0cfe2b7d40435
(how to share your site Read-Only link)

Hi, @grantsenior!

Thanks for reaching out about the dropdown workaround. I was able to take a look at your project, and the custom code that will work best is as follows:

.w-dropdown-link { white-space: normal !important; }

Feel free to replace your custom code with the above, and the text should wrap as expected:
CloudApp

1 Like

That worked.
Thank you!

Grant