Streaming live at 10am (PST)

Dropdown should open on click, instead goes to page


#1

Hi, I’ve got a Nav bar that won’t behave properly. I’ve obviously done something wrong.

I have 4 drop down menus in the nav bar, I want them all to behave the same: open on click.

Except, despite all having the same link block settings, when you click one of them (Industires) it immediately jumps out to another page before the dropdown menu is even open for a millisecond.

Besides I should have used Navlink instead of link block is there anything else I am doing wrong.


https://preview.webflow.com/preview/genius-home?preview=681f863082616c8e091930138e502c29


#2

I looked at “Solutions” nav link first.

  1. When you insert the dropdown component, you don’t need to go into the inner items to adjust anything. You can just add a class name to the Main Outer Dropdown layer.

  2. Don’t need to add a link destination to the main outer dropdown, this will take you link to another page. It opens to dropdown when clicked, nothing special needed.

  3. Nothing else is necessary, no link block or anything. The component has everything for you. Simply drop it in, add a class, then open menu in settings and change the link names by clicking each one and type, then they will have a link destination. Nothing outside of these inner links needs anything, other than a color if you want. But the Dropdown component is naturally transparent.

When adding the component, it’s already on the main outer layer. Immediately give this a class. After, you click on Settings, click Open Menu, click inside the links and change names.

Now it’s sneaky - if you double click the dropdown component, it will take you to the Dropdown Toggle one layer deep. Grr. I typically don’t mess with those two layers inside. :grinning:

Start over with 1 Dropdown component, add class, change links - then copy it and give combo class to each copied.


#3

Thanks! That is fantastic and incredibly detailed advice! I will follow it to the letter. Cheers!


#4

Not a problem, glad to help. Have Fun!!


#5

This topic was automatically closed 125 days after the last reply. New replies are no longer allowed.