Streaming live at 10am (PST)

Dynamic Link doesn't pull the correct link


#1

Hello community

I have a link text on a blog that i want it to take me to the category that is referencing but it takes me to the same blog post instead, could any one take a look?


Link that suppose to link to it's category...


Dynamic link configuration

And yet I get this:

I leave you here my preview link and the live site

Thanks in advance!


#2

Anyone on the webflow community?


#3

Hi I'm looking at it.

First, thanks a ton for the detailed request... illustrated captures, all the needed links, if every request was like that :smiley: Love it.

Second: what a site! Quite some work! Kudos. I see that you too must be interested in a multilingual support :smiley: (I am too)

Now when I open the blog post tpl in the designer, here is what I see, when I select the category button:

I see that it is linked to the current post.

And if I change it to "Category" (not "categories template" like in your capture, which I don't see as an option), I am actually well directed to the Motivational category page when I click the button, as expected I presume.

It's a bit confusing, I don't know how you end up with those links. I hope my demonstration can help you figure this out.


#4

Thank you for the kind words @vincent

It is quite strange indeed, a few days ago I had those link like you're mentioning but for some reason I don't get those anymore, I thought it was an update or something. I notice that every time I want to access any site on my dashboard the designer doesn't load at first and stays loading so I need to refresh a couple of times

maybe I should send a message to @webflow.

Now the link is working! Maybe it just needed to get some attention haha.

Thank you so much!


#5

Yeah I really don't know what happened... Glad it works now!


#6