Streaming live at 10am (PST)

E-commerce bugs; No web payments / cart shows NaN with weight based shipping

Hi, i have several issues with my live site:

01. Web payments - The cart stopped working all together with web based payments. I have had to disable that payment option. How / when is this going to be fixed? The client wants web payments to work.

02. Cart not accepting payments - with weight based shipping the cart shows ‘NaN’ in the total and does not work. Looking on the forum some other people have had this issue back in March last year. Why is it still happening. The site is live and cannot accept payments!

I emailed support on the 1st but have heard nothing back. I can’t wait any longer for this to be resolved.

Support doesn’t work on weekends. Just be patient.

Can you describe what is happening. I run sites with both you options without any problems

Hi, janneWassberg,

01: Enabling web payments stopped the cart from accepting any products in to it - now disabled.

02: The check out shows ‘Nan’ in the total leaving the user unable to proceed with payment. I have two different shipping options. a) weight based for most of the products and b) item based (because weight would work way much too expensive for this particular product - it can be packed two in a box so weight would double the shipping costs) for a collection of other products. As you can’t specify individual shipping options i’ve had to create three separate item shipping options for the ‘small’ ‘medium’ and ‘large’ to get round it. Not ideal but best solution we could come up with.

Regarding your 1:st point I don’t have a clue. Mine is turned on and do not have any problems think we have to leave this to the support van you @WebDev_Brandon take a look at this

Thanks for trying JanneWassberg - appreciated it… over to you @WebDev_Brandon

You second point. I know that wheigt is not a problem how did you create your item based option? Sure they are an option at check out

By not assigning a weight to the lampshades the only shipping options that come up are the three: Small Medium and Large shipping prices

was working fine but then it stopped…

Is it a weight rule?

You think every product has to have a weight assigned for the whole payment to process to work… okay i’ll add a weight but was hoping not to show the weight based shipping costs

Pls let me know how it works out

will do… just trying to hack a lightbox masonry grid before i can look

i’ve given all the lampshades a weight but still not working…

Sorry for that. What I did on one of my sites to handle self pick up as an option was to play with the weights.

I did have normal weights on some products and low weights on other products. When products with low weights was shooter I named the shipment as pic up… don’t know if you can try something similar with this idea.

Do you have a link to your site so I can look at it? Just a regular link will be fine

Sure: https://www.elizabethhaydesign.com/

Issue is the lampshades come in 5 different sizes and the largest, because it needs a larger box, can cost a lot with a normal courier and two can be packed in a box in one go so weight based shipping doubles the cost unnecessarily .

Ok now I se what happens. I got the same problem with ITALIAN SCONCES.

What differs the shades and ITALIAN SCONCES from the other products regarding shipment? It seems to be related to the shipping.

PS. Nice site :+1:

On top of my mind I think the weights rules are out taking each other.
Have you tried to break it down, and add rule after rule

Thanks… that’s the issue, they’re all the same now.

Even with Singapore, which has two different options: flat rate and free over $500 - that doesn’t work either… running out of options. Are there any other Webflow staff on here you could suggest to have a look asap??

good idea… will try but runs the risk of someone picking the wrong shipping