Streaming live at 10am (PST)

Editor Preview Error


#1

Preview not showing Dropdown correctly. Dropdown works in Interaction preview, but not in Editor preview.


Here is my site Read-Only: https://preview.webflow.com/preview/davids-superb-project-c6e-a55cb9545048a?utm_source=davids-superb-project-c6e-a55cb9545048a&preview=bbc35496badcb78f7233a8afbcb04886

(how to share your site Read-Only link)


#2

Hey @bronxbomber

This isn’t a bug, this is down to having two conflicting interactions… You’re using the native Menu button to try and create a dropdown interaction which won’t work.

If you want the slow dropdown effect, then you’ll need to remove the native menu button altogether and create it manually with a dropdown button using this guide I made here.

If you need further help then just reply here and I’ll try and put a video together.


#3

I created this dropdown myself. I’m not using the menu button that comes with the Navbar. I only kept the icon to make it look like the original menu button. Did you get to watch the video? The preview works in the Interaction preview, but it doesn’t work in the Editor preview.


#4

Thank you for the video guide. It helped. Did you make a custom dropdown in the video or did you add interactions to the Menu button that comes in Webflow?


#5

You can make this easier for yourself by using the native Webflow components so the main navigation on desktop is used in the mobile versions too with the interactions you want.

The interaction is made using the native Webflow dropdown. When using that, you’ll see a new setting appear in the IX 2 menu for “dropdown” interaction.


#6

Ok thanks. I’ll check that out.