Streaming live at 10am (PST)

Elements Not Nesting Correctly in Link Block Wrapper

Hey guys,

I’m having a problem figuring out why for one of my category collections pages, the link block isn’t correctly nesting the elements inside. It works fine for the “HyperFocus Series” category, but not for the “Eclipse Series” category.

Attached are the pictures displaying the issue below.


Setting it to “Wrap” fixed the centering problem as you’ll see in the next picture but still does not fix the fact that the elements on the “Hyper Series” category aren’t nested correctly in the link block and the border goes over the image.

I’d appreciate any help on this. Thanks a lot in advance.

Site Link: https://preview.webflow.com/preview/project-x-656339?utm_medium=preview_link&utm_source=designer&utm_content=project-x-656339&preview=ba896378bc174c2f844e58042e722287&pageId=5de624494a598601d962c64c&itemId=5df89fa3767badf82adf5612&mode=preview

I clicked on your link block container and changed the VW to 80 and it centered it in the box. Try that.

Hi Joseph,

Thanks for the reply but if I do that it skews the products inside of the other collection i.e. “HyperFocus.”

Hi @g4av1n, thanks for the post, I am here to help.

I have made a quick video: https://share.getcloudapp.com/geurb2NR

I would update the styling on the image to remove the max width and height, set the width to 100%, remove left and right margins set to auto and set the collection list 3 class to a justify center in flexbox settings

I hope this helps

1 Like

Thank you, @cyberdave! You are amazing. Thank you very much, I really appreciate you taking the time to show me what the problem was. :pray:t3: