Streaming live at 10am (PST)

Email form Success and Error messages displaying on mobile device when page loads


#1

I'm having an issue where the success and error messages are both displaying below an email form only on mobile devices. Specifically the landscape and portrait phone. I can't seem to get rid of them and they don't display on the web and tablet sections. Please help!

https://webflow.com/design/blues-and-swing?preview=2982589314f5d5eda1ce9f1021d9cfed


#2

Hi @satoriglass, it looks like you have customised the Success and Error message containers with different colors and fonts, and you have left the display set to block, which overrides the original display:none setting that hides the success and error messages. Can you please set your Success message container to display:none and also do the same thing for the error message. Try that and see if it fixes your problem.

Cheers


#3

Thank you so much cyberdave!! That fixed it! Wish I would have posted here before I spent a few hours trying to figure it out myself stuck_out_tongue.

Thanks again!


#4

Great, welcome to the Webflow forum community !


#5

@cyberdave helped me aswell!
webflow guys should've fixed the issue to automatically give these 2 style a default of none..


#6

Hey, I'm reviving this conversation since i got the same problem (also on desktop), but the solution @cyberdave gave doesn't work for me.
In fact, I can't even change the display settings of the error message:

Here is my public link

Thanks


#7

Hey @Orimanor thank you so much for posting this. I just took a look at your site and was able to resolve the issue by performing the following:

Add another div block to your site and use the same class name "Form Error" on this div block (same class name used on your form error). Then click the "Display Setting" blue link at the top of the Styles tab and click the "Remove this style" button. That should resolve the issue. :smile:

​Please let me know if this solves the problem, if not, I’m happy to help further :slightly_smiling:


#9

Thanks, its worked :smile:
But why was there a problem in the first place?
Shouldn't the error message be display: none as default?


#10