Streaming live at 10am (PST)

Email notifications for form input are not being received

Hi Guys,

I am fairly new to webflow and builded my first site. I am trying to make a Free discovery call form which can be found when you press the Free Discovery Call button. However when I test it, the input does not receive my inbox. I have tried with an alias and also white listed IP adresses & domain.
However I still do not receive email notifications?

Have you guys encountered this before or know how to fix this issue?
Thanks in advance

https://preview.webflow.com/preview/melanie-peggy?utm_medium=preview_link&utm_source=designer&utm_content=melanie-peggy&preview=36dfc1a692ac981181211102146f9323&mode=preview

There are other users reporting the same problem this morning so it’s more than likely a bug:

Hi Mike,

Thank you for your quick reply, just refreshed and tried again, stll no luck :frowning:

Since this morning is a good 18 hours ago in GMT Europe and we are the slowest part of the old world.

I think there is a clear need for somewhere other than West Coast Pacific USA support hours as it’s so far behind the rest of the planet.

I’m just speaking for what I’ve seen since logging on this morning (PST, in Oregon USA), so I can’t say when issues started.

Definitely agree that support could be expanded, however I believe the main office is in San Francisco, CA which is why most of the time is relative to the West Coast time zones. That said, I don’t work for Webflow so unfortunately I can’t really speak to what’s being done to improve things on that front.

Morning Guys ( I am in Amsterdam)

Just tested again and it is working now, maybe a delay or maybe a bug I don,t know.