Streaming live at 10am (PST)

Embed code breaking interactions

I’ve added a Navbar interaction that hides when scrolling down and appears when scrolling back up. One of my pages I added a custom script that snap-scrolls to each section. When I do this though, it cancels the navbar interaction.

If I remove the embed code it works as intended. I haven’t had any luck finding a solution so any advice is appreciated.

Thanks in advance.


Here is my site Read-Only: Webflow - NJPB Final

Hi @janderson,
have you deactivated the custom code snippet?
For me, the site is working fine, but also nothing is snapping anywhere.

Maxi

I’ve only disabled the snippet on devices less than ~900px. The way it works right now is that you scroll wheel down one or two times and it will snap to the next section.

Still working on smoothing it out. Does the navbar move up and down when you scroll on that page though?

Ok, i think i was on the wrong site. The snapping is working for me on the design page. But the navbar is static. (doesnt move up or down)

Maxi

Right, snapping should work as intended. Any idea on why the snippet disables the navbar interaction?

Thats weird.

The header on the start page (animation working)

And your header on your design site: (no webflow ix)

You could try to delete and then add your site scroll ix again… But i had also problems with ix and custom code in the past. My solution was to either not use ix or not use this special custom code…

Maxi

Hm, okay, I’ll see if deleting then reading works. If not, I’ll just remove the custom code.

Appreciate the help, Maxi!