Streaming live at 10am (PST)

Embed Code not working -_-!


#1

Im having issues with using this generated code in the embeded widget on my page :confused: when i publish the update to view it realtime, nothing shows. I’m using SinglePlatform to keep my menu updated throughout all platforms (yelp, foursquare, google etc…) so I’d like to integrate it into my website as well. This is the code that SinglePlatform provides for embedding our real-time menu onto our website. Any ideas??


#2

Hello @gotaro

At the end of your script try “menuscontainer” class in lowercase.


#3

do you mean putting “<div id="menuscontainer"></div>” on next line after </script>??


#4

No, look at the last line of code of your script, “new BusinessView(“vintage-cave”, “menusContainer”, options);” > try changing “menusContainer” to menuscontainer".


#5

Also, it seems your are missing your api key at the end of your first script “?apiKey=” you should be able to find your api key in your SinglePlateform account param.


#6

Thanks for that Blaise, unfortunately it didnt work. The api key is actually there, its a scrolling box .

<div id="menusContainer"></div>
<script type="text/javascript" src="http://menus.singleplatform.co/businesses/storefront/?apiKey=ke09z8icq4xu8uiiccighy1bw">
</script>
<script>
    var options = {};
    options['PrimaryBackgroundColor'] = '#d9d9d9';
    options['MenuDescBackgroundColor'] = '#d9d9d9';
    options['SectionTitleBackgroundColor'] = '#f1f1f1';
    options['SectionDescBackgroundColor'] = '#f1f1f1';
    options['ItemBackgroundColor'] = '#ffffff';
    options['PrimaryFontFamily'] = 'Roboto';
    options['BaseFontSize'] = '15px';
    options['FontCasing'] = 'Default';
    options['PrimaryFontColor'] = '#000000';
    options['MenuDescFontColor'] = '#000000';
    options['SectionTitleFontColor'] = '#555555';
    options['SectionDescFontColor'] = '#555555';
    options['ItemTitleFontColor'] = '#555555';
    options['FeedbackFontColor'] = '#555555';
    options['ItemDescFontColor'] = '#555555';
    options['ItemPriceFontColor'] = '#555555';
    options['HideDisplayOptionPhotos'] = 'true';
    options['HideDisplayOptionDisclaimer'] = 'true';
    options['MenuTemplate'] = '2';
    options['MenuIframe'] = 'true';
    new BusinessView("vintage-cave", "menuscontainer", options);
</script>

#7

Welcome to the Webflow forum!

Could you please edit and provide ALL the necessary details in your post so we can take a look at your site/issue?

In future if you want faster replies and more accurate answers, I suggest including all the details listed in the link above before someone has to ask.

Hope to hear from you soon. Thanks!


#8

Thank you Sam! I was hoping it was gonna be an easy fix. The code provided to me by SinglePlatform for embedding my menu in the website. To be clear, the instructions from SinglePlatform says to “copy paste the code into your webpage’s HTML”

<div id="menusContainer"></div>
<script type="text/javascript" src="http://menus.singleplatform.co/businesses/storefront/?apiKey=ke09z8icq4xu8uiiccighy1bw">
</script>
<script>
    var options = {};
    options['PrimaryBackgroundColor'] = '#d9d9d9';
    options['MenuDescBackgroundColor'] = '#d9d9d9';
    options['SectionTitleBackgroundColor'] = '#f1f1f1';
    options['SectionDescBackgroundColor'] = '#f1f1f1';
    options['ItemBackgroundColor'] = '#ffffff';
    options['PrimaryFontFamily'] = 'Roboto';
    options['BaseFontSize'] = '15px';
    options['FontCasing'] = 'Default';
    options['PrimaryFontColor'] = '#000000';
    options['MenuDescFontColor'] = '#000000';
    options['SectionTitleFontColor'] = '#555555';
    options['SectionDescFontColor'] = '#555555';
    options['ItemTitleFontColor'] = '#555555';
    options['FeedbackFontColor'] = '#555555';
    options['ItemDescFontColor'] = '#555555';
    options['ItemPriceFontColor'] = '#555555';
    options['HideDisplayOptionPhotos'] = 'true';
    options['HideDisplayOptionDisclaimer'] = 'true';
    options['MenuTemplate'] = '2';
    options['MenuIframe'] = 'true';
    new BusinessView("vintage-cave", "menusContainer", options);
</script>

When I paste that into the embed widget on webflow, the published site shows a blank. Is this code not compatible? Doesn’t seem to complex…


#9

Hi @gotaro,

Please complete items 1,3,5 in the guidelines otherwise I am unable to help. See link I posted above.


#10

@samliew, Thank you for your assistance, i really appreciate all the help i can get. I dont feel comfortable sharing the read-only link publicly at the moment. Could I send it to you privately? As for steps 3 & 5, I attached it below, seems like there are errors under the developer console.

37 PM


#11

ahhhh i got it to work! i had to use HTTPS in the script. THANK YOU @samliew & @Blaise_Posmyouck FOR YOUR TIME :pray:


#12

Oh, the https :slight_smile: glad you found it yourself !
Best


#13

Now this is an example of why we request that the guidelines are followed. Even better if you can solve it yourself with the hints in the console!


#14

Understood. Thank you for your time!